Results 1 to 9 of 9

Thread: Wad Manager Error Ret=-1

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Posts
    20
    Thanks
    7
    Thanked 3 Times in 3 Posts

    Wad Manager Error Ret=-1

    I recently to set up my External USB drive with dual partitions. 1 WBFS, and the other Fat 32 (Primary: for Triiforce). The WBFS backups work great, no issue. I created a NAND Dump with Simple FS Dumper 0.2. Copied it to the HDD. Triiforce and Wad Manager seem to load the NAND correctly.

    Whenever I try to install a wad with Wad Manager. I use my SD card as the source, and USB 2.0 as the NAND Emulator. I get an Error Ret=-1.

    Reading from other peoples' issues it could be a naming of the "wad" directory, not here though... Some also claim it could be due to a bad Wad file, which is also not the case... I can install WAD's from the SD card to my internal NAND.

    Any help would be greatly appreciated, I have been scratching my head over this issue for a few days now. Thanks!
    Last edited by CRKFIEND; 12-18-2009 at 06:20 AM.

  2. #2
    Senior Member
    Join Date
    Sep 2009
    Posts
    4,784
    Thanks
    787
    Thanked 1,791 Times in 1,262 Posts
    Blog Entries
    5
    Check out the error index in my sig.

  3. 1 User Says Thank You junkmail For This Useful Post


  4. #3
    Junior Member
    Join Date
    Dec 2009
    Posts
    20
    Thanks
    7
    Thanked 3 Times in 3 Posts
    Thanks for the fast reply. I don't believe it's an incorrectly installed IOS, I used the softmod guide in your signature, and followed it to a T. It's not an incompatable USB drive, as it's listed as working on the compatability list, and it loads the nand off of the USB drive. Any other ideas?

  5. #4
    New Member
    Join Date
    Nov 2009
    Posts
    14
    Thanks
    0
    Thanked 2 Times in 1 Post
    ret -1 means that there is a problem reading from the sd card. I had this same issue when I was trying to install wads from wad manager. Bought a new sd card and problem went away. hope this helps.

  6. 2 Users Say Thank You to fhaniff22 For This Useful Post


  7. #5
    Junior Member
    Join Date
    Dec 2009
    Posts
    20
    Thanks
    7
    Thanked 3 Times in 3 Posts
    I've been using an SDHC card, I bought a 2gb SD card today though... I will let you guys know if it works when I get home. Thanks!

    EDIT: I just find it weird that I can install to the internal nand with the SDHC card....

  8. #6
    Junior Member
    Join Date
    Dec 2009
    Posts
    20
    Thanks
    7
    Thanked 3 Times in 3 Posts
    no such luck, the sandisk 2gb sd card still returns with the ret=-1 error...

    I can still install wads to the internal nand though... anyone else have any good brainstorms?
    sorry about the lack of caps, im on a netbook... last 2 times i used them, it deleted my post...

  9. #7
    Junior Member
    Join Date
    Dec 2009
    Posts
    20
    Thanks
    7
    Thanked 3 Times in 3 Posts
    UPDATE:

    I copied my NAND to a 2GB SD card. It worked correctly. Should I assume that my drive is incompatable with Wad Manager? Because it works fine for everything else. It's formated FAT right now.

  10. #8
    Junior Member
    Join Date
    Jan 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am having the same problem right now. I've been following the guide here and have had no problems right up until Step 5b. I have 1536 blocks open on the SD card and 1021 on the Wii. Is going out and buying a new SD card going to solve this? I am currently using a 1GB SD card formatted for FAT32.

  11. #9
    Junior Member
    Join Date
    Jan 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am getting similar errors. I am able to see the IOS's in the WAD file but can not load. I have to use the usb storage driver to access the SD card. Then I pick the ISO60-patched.wad and get the error ret=-1. I have tried a different card with the same error. I have also downloaded the files again with no changes. Step 5b is where I am stuck. Any help or pointers would appreciated.

    Thanks,
    Jonathan

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •