Results 1 to 2 of 2

Thread: R4 SDHC recognizes sandisk micro SD but doesn't recognize knigston micro SD

  1. #1
    Junior Member
    Join Date
    Aug 2008
    Thanked 0 Times in 0 Posts

    R4 SDHC recognizes sandisk micro SD but doesn't recognize knigston micro SD


    I've bought a few R4's which run on the firmware from They work fine with sandisk micro SD but they don't recognize kingston micro SD, weird. The kingston's work fine in R4i red box flashcards. I even tried formatting the kingston micro SD with panasonics sd formatter tool, still no joy. I have a fair bit of experience with flashcards but I've never come across anything like this.

    One other thing i thought was unusual was that the data transfer rate on the kingstons I have is very slow, about 2 or 3 mins for 20mb when it's about 20 seconds for the sandisk.

    I have tried 4 kingston micro SD's 2GB and 4GB and they are all brand new.

    Has anybody any idea why this is happening and if there is a fix


  2. #2
    Junior Member
    Join Date
    Jun 2009
    Thanked 0 Times in 0 Posts
    from what ive been told the r4 sdhc is a r4 clone... i got one too and i knoticed alot of issues with it compare to my friends normal r4 card.

    so far the only card ive tried with it is pny 2gb and sandisk 4gb and a samsung 2gb

    all work fine, except the games tend to freeze randomly with the pny, no suprize tho as its the cheapest sd in this area

    But yea it being a clone is the only thing i could think of that would do that.... my friends r4 uses a kingston 2gb

    So yea i know for sure mines a clone, cause everyone says it is.... Got mine off of deal extream or w/e its called
    Last edited by Sonis; 12-17-2009 at 11:47 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts