First of all this is my first time trying to hack a wii and from what I can understand it shouldnt be too hard...

I got my Wii on the first day it came out and the firmware version is 4.0

I installed HomeBrew Channel with bannerbomb everything went OK

Then I installed DVDX or whatever its called ( is it supposed to add a channel? whats the real purpose of this?)

Then I tried to install bootmii as boot2 but I could never mount the file system on my SD card...

then I tried to install the app called Homebrew Browser from HBC and everytime I got the same error it can't mount my SD card it just goes on and on and never will be able to mount the SD card...is it a problem of compatibility with my SD card? I got a 4gb DURACELL SDHC

Then I talked with a friend of mine who told me I needed cIOS36_rev10 make it work...is it true?

So today I tried to install cIOS36 installer, you can either do it from network but everytime it fails to install cIOS after all the patching is done.

Then I saw there's another method to do it with wad files but I still get an error, it will mount my SD card then I can see he found IOS36-64-V1042.wad but then I got the message : ERROR! (ret-1) what does that mean?

all in all, do I have to get cIOS36_rev10 to work to be able to make work Homebrew Browser?

Its either a problem with my SD card or I fucked something.

Here's pictures of whats on my SD card.