Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Virtual CD partition on Toshiba 640GB USB drive

  1. #1

    Virtual CD partition on Toshiba 640GB USB drive

    I am beyond frustrated at this point. I have been using Configurable USB successfully for quite some time on my 8GB USB stick to play a couple of the games that have trouble being played on DVD (ie: Ghostbusters, NSMB). I got addicted to the ease of use, so I bought a nice big 640GB Toshiba USB drive to house all my games.

    Um yeah. Stoopid thing doesn't work. Well it DOES, but not with Wii. I have tried every USB loader imaginable, nothing. Yes I have Hermes installed, yes I have the WBFS partition set to primary and active. I formatted to both FAT32 and NTFS before formatting to WBFS and STILL nothing. I am beginning to think I wasted $80. I mean WBFS works and the drive is seen by WBFS Manager and I can move games onto as if it DID work, but still get stack dump and ISI errors when I try to access it with a loader.

    I believe the problem lies in the auto-booting virtual CD partition which ALSO shows as primary and active (I guess since it's a different type of partition), but I can't get RID of the stoopid thing. Can't fdisk it, no tools I've found work, nothing. Anybody else have any ideas? I normally don't ask for help as I've been able to sort through this stuff on my own before, but this has me stumped. Not to mention I doubt I can send the #$&(#*&ing thing back since I've messed with it so much.


  2. #2
    Wish I could help with the disc partition (I can't stand the pop ups on my pc external hdd), but if nothing else I wouldn't rule out being able to take it back. Playing dumb works wonders... I've returned about 6 usb thumb drives because I wbfs formatted them and they ripped to slow for my liking.

  3. #3
    I wound up calling the 800 number and they let me take it back to the store. The biggest they had in stock there was a 320GB WD My Passport so I grabbed one of those and it works great!

    It also has a virtual CD partition you can't remove, but at least WD puts out a tool on their website to shut the blasted thing off. Saved me a little money too for now. I figure later on when I outgrow the drive, I can turn the virtual CD thingie back on and use it as a backup drive for the laptop.

  4. #4
    I have this damn drive, too. You're right, WD at least gives you a tool. Search for that at Toshiba's site and it'll give you firmware updates for a fridge. Nah, j/k, but Toshiba's pretty useless. Got it for a great price so I don't really want to give up on it just yet.

  5. #5
    I'm in the same boat. I have a similar drive, a 1tb Toshiba, model # PH3100U-EXB. I'm getting exception isi upon any homebrew app attempting at reading the HDD. I'm almost 100% positive it's the virtual CD.
    Sadly, Toshiba is garbage and they don't have any removal tools for this, so I've spent about 3-5 days or so searching for a solution.
    95% of people just say "have you tried formatting it". I've formatted it like 90 times with numerous softwares under multiple operating systems. Just doesn't seem like something I can accomplish without opening the damn thing up and finding out what the controller chip is. Maybe that'd help.

    Anyways, I will keep on continuing my search. I bought this back in October so I can't really return it. Best Buy said they might exchange over the phone, but I probably won't be able to get my way over to one any time soon.

    I'll post of any updates. Also if any USB related tool devs want to try and find a work around, let me know, I'll guinea pig it up.

    Also, anyone with this drive may want to check out,8 as that may work. Those tools say my device isn't compatible, but it might work for you. I've read that that works for some.

  6. #6
    I got another tool you can try, it didn't work for my 1tb model but it might work with others.
    Toshiba Drive Converter_V1.06.exe

  7. #7
    Have any of you tried booting a linux cd and trying to format the drive? I imagine it might be able to completely format the drive. It's worth a shot.

  8. #8
    Quote Originally Posted by xtreme777 View Post
    Have any of you tried booting a linux cd and trying to format the drive? I imagine it might be able to completely format the drive. It's worth a shot.
    That doesn't work, since the virtual cd isn't actually part of the hard drive but a separate component. But I have indeed tried formatting under linux.

  9. #9
    Looks like Toshiba answered my prayers (possibly):

    Model Content Page

    I don't really want to test it out immediately (I have 160gb of stuff on it and only 20gb on my main hdd) so I can't report any results immediately. Click on "The Desktop External Hard Drive Powers Off and is No Longer Recognized by the Computer" and scroll down, the drive converter link is near the bottom. Apparently there's some other issue that I don't have that has lead to this potential fix.

    Hopefully this helps someone. Let me know if USB loaders work with your drive after this.

  10. #10

    It worked!

    Hi there.

    After I did what is said in the Toshiba Page you told in your last post, I turned my before useless 1TB Toshiba HDD into a pretty Usb Loader device! I read and did exactly what the page said. The Virtual CD was gone after that.

    I was filled with such emotion after I saw it running on both WiiFlow and Usb Loader GX, it works very well and loads nearly instantly in many games.

    Thank you so much for your last post, I would have never checked up the Toshiba official page after all what I read about it in some other pages.

    Oh, I missed something: After the step 8 of the procedure in Toshiba's resolution, I got an error message "Firmware wasn't able to update.", and the screen (that supossedly had to run in the step 10) didn't appear. I just had to format the partition with another partitioning program (because the toshiba's application only erased every partition after that error, including the CD ). And after all that, it worked out perfectly! Hope it already worked for you.

Page 1 of 2 12 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts