Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: Preloader but system menu/HBC/Boot.dol errors

  1. #1

    Preloader but system menu/HBC/Boot.dol errors

    Hi, I have posted this twice elsewhere. Still hoping someone can help out or let me know if there is no hope, I have been looking at similar posts but haven't been able to put all the pieces together.

    I had researched softmodding a wii and gave instructions/files to my housemates (downloaded a set of file spec for hack on 4+ wii).

    They tell me they followed instructions and in the end they had HBC but could not load backups, in the process of checking this they noticed messages about updating HBC and preloader. In updating one of these two the system is now showing errors.

    Preloader loads ok.
    System Menu fails to load complaining about corrupt file system.
    Can't load HBC from preloader (talks about missing title)
    Unable to re-install boot.dol (DSI exception)

    I have searched for the above issues and I can find guides to correcting all but the dsi exception which seems to be what we need to get HBC working and reinstall the system menu.

    The guide for repair that I tried following was but we can't do #3 due to boot.dol having the exception.

    If it is any help I'm in Aus so running a PAL machine.

    Can anyone help us restore the wii so we can start again?
    I think I'll follow some guides here this time if I can get to that point.

    If I have missed something in searching please feel free to point it out, however this isn't a quick fire post it is after hours of searching/trying.

    Cheers in advance

  2. #2
    No reply? does this mean I have no hope or I'm asking a stupid question or in the wrong place?

  3. #3
    hi m8 try this one .i had the same prob its a bit of a mess on but i got it done in the end hope this helps u out m8

  4. #4
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Sunny Wales, UK
    What System Menu version and IOS does Preloader display at the foot of the screen?

    Not sure which boot.dol you were trying to load but that option in preloader can also load any homebrew application, including hackmii installer, wad manager etc which could help unbrick.

    Do you have bootmii/boot2 installed?
    Not really doing much Wii stuff these days.

  5. #5
    Thanks char1981, I'll have a close read and see if that will solve it.

  6. #6
    Thanks for the reply Tealc,

    The stuff at the bottom of preloader are:
    IOS v50
    System menu v386
    Preloader v0.29

    No we don't have bootmii/boot2 installed.

    Another question, does it sound like a full or semi brick state?

  7. #7
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Sunny Wales, UK
    Sounds like HBC has been removed for some reason and a 'preloader on 3.4 brick' (really must think of a catchy name for that)

    The method to remove this issue is to re-install IOS50v4889.wad and System Menu v386.wad to get rid of preloader.

    You need to use the Load/Install file option to boot wad manager.

    Download Wad manager 1.5. or Wad.Manager.1.5.Folder.wiiNinja.Mod3.rar

    Extract the .dol file

    Rename .dol file to boot.dol and place in root of your SD.

    Download IOS50 and System menu v386 IOS50-64-v4889.wad 3.4E-System Menu-PAL-v386.rar

    Place in sd:\wad

    Start preloader and choose Load/Install file.

    Wad manager should start, skip through options choosing IOS249, SD card and Disabled for NAND emu, eventually you'll get a list of the two wad files.

    Install IOS50v4889.wad first (IMPORTANT)
    then SystemMenuv386.wad

    Not really doing much Wii stuff these days.

  8. #8
    Thanks for the detailed response Tealc,
    however when using the wad manager and choosing IOS249 it goes to a black screen with Exception (DSI) occurred! ... CODE DUMP.
    Is that helpful at all?

    Again thanks for spending the time to help.

  9. #9
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Sunny Wales, UK
    Maybe your cIOS is all messed up too.

    Now it could get complicated. Next thing I'd do is re-install cIOS38rev14. Grab the installer from my mediafire(click my signature) and rename/launch the boot.dol from root of your SD. Also place the IOS38 file at root of the SD.
    Not really doing much Wii stuff these days.

  10. #10
    I just ran into the same problem, fixed the system menu load by going into settings and changing the system menu IOS from 70 to 36. I still don't know how to fix the HBC load issue. Hope this helps.

    edit: btw 36 worked for me, I don't know if that's the case for all wii's. I guessed that number because when I installed my cIOS I recalled that it worked with IOS36.
    Last edited by kaiserlucifer; 11-11-2009 at 06:02 PM.

Page 1 of 5 123 ... LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts