hey everyone, i just recently got a chipped japanese wii when i went on holiday to HK and got a NTSC game with it. The guy who sold me it told me that it could play any region and copied games whatsoever. I went home and set it all up and it worked brilliantly with the NTSC game.

But then when I went back to the UK, I decided to download 'The Legend Of Zelda: Twiilight Princess' (PAL) iso and burnt it on a DVD. I put the DVD in the wii and at first it worked fine and the first box in the screen that showed what was in the drive showed 'The Legend of Zelda's' title screen so I clicked on it which brought me to the screen saying 'Go back to Wii' and 'Play' or whatever, I'm not sure it's all in jap, so I clicked on play but then the screen went black and the remote control lost its bluetooth connection, but the wii was still turned on. I thought I burnt the iso wrong so it didn't work, so I went out and bought Super Mario Party 8 (PAL) but the same thing happened with it!

I then found out that it happens when there's a region block on the game (?) or something along the lines of that, but my wii's chipped?

Please give me any suggestions on how to solve this problem! I also don't know which chip is in my wii...so...yeah...=[