Results 1 to 10 of 10

Thread: Wii unable to read some discs after inserting modchip

  1. #1

    Wii unable to read some discs after inserting modchip

    My Wii (bought two months ago in Canada, brand new and untampered) just got a modchip yesterday (it was $60 including installation, but I've yet to confirm what chip it was), and some games work fine, while others will produce a "an error has occurred. Press the Eject Button and remove the disc, then turn the Wii console off and refer to the Wii operations Manual for help troubleshooting." error. Oddly the ones that work will also produce that error sometimes, and need to be re-inserted a few times before it works. Also, other games in the same series will not work, for example DDR1 works, however DDR2 doesn't; likewise Resident Evil 4 works, but Resident Evil Umbrella Chronicles doesn't. The modified Wii is able to play Japanese games.
    I don't think there is anything wrong with the disc as I didn't download and burn myself, I actually got it from stores.
    Does this have anything to do with installation of Homebrew Channel? Or is it something else I'm not doing right?

  2. #2
    i dont see hbc being any problems like that

    it may be one of the solder points arent contacting properly but im sure there could be other issues that can cause that so wait for more responses before taking apart your wii.

  3. #3
    That could be the point. I will ask the people who installed about it.
    I just checked my Wii version, it is 3.4U. Does that have anything to do with it?
    Also I heard there was another way to "unlock" the Wii, by using software methods? Like installing some program or something via disc, not by physically taking apart the Wii and placing a modchip. Are there any differences between these two methods? Will the software method correct this problem I'm having?

  4. #4
    3.4 wont have anything to do with it alone, and yes there are soft mods you would need an sd card and a external usb hard drive

    Compatability List:
    USB Devices Compatibility List - WikiTemp

    you would have to use the banner bomb hack to install homebrew channel so you can use programs like usb loader gx and usb loader 1.5 by waninkoko

    only difference i see is being able to backup your games on a hard drive and not using disks so not worrying about scratching ... if you decide to go that route there are tutorials everywhere on how...


    USB LOADER 1.5 by waninkoko
    Last edited by karrade; 08-18-2009 at 01:22 PM. Reason: Adding Info

  5. #5
    Senior Member
    Retired Head Admin

    Do NOT PM for Site or Wii Issues
    Gen3SF's Avatar
    Join Date
    Jun 2009
    San Francisco
    Hey Chocolate,
    With that intermittent problem, I would suggest you make sure the DVD lens is clean. With the case opening up for the chip mod, storage, transport, etc. it's not uncommon for the lens to just get dirty and act kinda lile what you are seeing. Buy a cleaning kit and give it a go. Good luck.

    <If the information provided was of help, please press the little thanks button>

  6. #6
    Thanks for info on software unlock and cleaning the lens. The discs run fine now so I'll only try the cleaning if they start producing that error again. However the other discs still produce that error. Maybe they are just incompatible with the 3.4U system, or the modchip unlock didn't completely bypass version checker or something. Would a complete unlock that bypasses version compatibility be something that would solve the problem? Or how about downgrading the 3.4U to something earlier, like 3.2? Is it worth it to try download those games and burn discs myself and try to see if it works?

  7. #7
    Hmm I tested the discs on a friend's Wii and they all worked. She used modchip to unlock the Wii also, however the only difference is that her Wii is 3.1U instead of 3.4U.
    I asked around elsewhere and people say that installing either HBC or using "softchip loader" (haven't heard much about this but they say it's supposed to be the newest method for software-unlocking).
    I'm not going to tamper with the Wii myself, I'll have to bring it to the people who installed the modchip, so do you guys know anything about this softchip loader or however it's called? Is there a chance HBC or this has anything to do with the fact my Wii is incompatible with discs that work on 3.1U?

  8. #8
    did you try cleaning the lens like gen3sf suggested? my post above has the hard drive compatability list you would need for the soft mod and my signature on this post has the other links you need.

  9. #9
    Order yourself some Verbatim DVD-R from Its currently 21.99 with free shipping for a 100 pack. Had similar issues with Memorex. Some games worked, some didnt. Some worked for a while into the game then froze with an error. Since switching to Verbatim, all is well.

  10. #10
    Junior Member
    Join Date
    Sep 2009

    For any Disc related errors try to use Verbatim DVD-R first before troubleshooting...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts