Results 1 to 7 of 7

Thread: 3.3u upgraded to 4.0u won't read sd card anymore, but wii can

  1. #1

    Question 3.3u upgraded to 4.0u won't read sd card anymore, but wii can

    Hello all,

    I've been searching here, google, and other places for the past 2-3 days. I have not come across anyone else having an issue quite like this. If they have, then I misread some posts and apologize in advance. For the sake of brevity, here's what's going on.

    3.3u Wii

    Hackmii bannerbomb added HBC, GC Backup Launcher, & Wii Backup Launcher

    BootMii installed in boot2 (whichever is the ideal place for brick protection)

    I HAVE INDEED made a working backup of my 3.3u system. I've actually used it as a temporary solution to the problem at hand, so I know it will successfully turn my 4.0u system back to a 3.3u system. While this is a working solution, it's not the one I want ultimately.

    Successfully installed SMB2(Lost Levels) VC from SD card.
    Successfully booted a GC backup and a Wii backup.
    Successfully added the USB Loader and associated channel
    Successfully ripped games to USB hard drive and launched them from it.

    HBC launches on 3.3u from my SD card (1.0 GB)

    Sounds good, right? Well, here's the issue. I was under the impression that an upgrade to 4.0 that maintained my mod would still add the IOSes I need for newer games. This is what the wife and I want. So, I followed a guide here regarding Waninoko's method. Before that, I followed a guide on a site I can't find now that said to install 2 or 3 files, then update the firmware the rest of the way with Wii's own updater. BOTH METHODS succeeded.

    Now, though, I cannot boot HBC (or any apps for that matter) off the SD card. This is the exact same card I used in the first place, the one that HBC worked from just fine when on 3.3u.

    Here's the weird thing: BootMii still launches if the card is installed at boot time. Also, the Wii's own system can use the card. The photo channel showed pictures from the card and the Wii's data management let me back up a game save to the card.

    Backups still boot as does the VC game.

    The only thing failing is HBC...and by extension, apps that require it for launching.. I click the HBC and the bubbles show up with the option to launch HBC or return to the Wii menu. Going back to the menu works fine. Starting the HBC gives me a black screen...and that's it. It doesn't eventually load after even 5 minutes. I have to hold down the power button to shut the system down.

    HBC is an option at the BootMii launcher too. Well, it gives me the same black screen lock up if I try to launch HBC from here.

    I don't get this. From my reading, the best I could come up with is a potential issue with the brand of card, but how then do the Wii and BootMii both use it with no issue? And why would HBC use it just fine on 3.3 but choke on 4.0?

    I've reformatted the card. I've put barely anything and also a whole lot of stuff on it. Nothing changes.

    My previous temporary solution was to restore 3.3 with BootMii. But I want to play the newer games with little fuss, hence 4.0 (unless I'm misinformed).
    Now I'm on my way out to get a different brand. But the fact that the Wii reads this one and BootMii can use it makes me wonder if something actually broke in HBC (like a config file or something simple).

    If anyone has any useful ideas, I'm open to them. I try to help here where I can. Now I am the one who needs help.

    Thank you in advance.

  2. #2
    wow, hell of a story. homebrew can act funny sometimes, I've had a case myself, which i spent hours trying to fix. Hope I can lend a hand or give you an epiphany...
    Have you tried a different memory card? It's obviously not the problem but cannot hurt to give it a go.
    Are you using the latest version of HBC (i think 1.0.3) or the previous one (again i think 1.0.1)?
    How did you upgrade to 4.0, nintendo or waninkoko?
    What cIOS are you using (although probably irrelevant)?
    Being on 4.0 doesn't mean you cannot play the latest games. No games require a sysmenu version yet. They require certain IOS files, which you can add or upgrade manually if necessary. Something happened in the 4.0 update that the HBC doesn't like, but you just have to figure out what it is. My apps were going crazy on me, and I didn't change anything, so I updated officially to 4.0 from 3.2 and it corrected my problem.
    EDIT: one more question, did you use IOS Downgrader to downgrade your IOS's?

  3. #3
    Hey VashTS,

    Thanks for the response...was starting to wonder if I'd ever get one.

    While I put a lot of detail for the sake of "did you read the tutor...oh, apparently you did. Well did you try...oh, yeah, that and every variation" not being an answer for me.

    I recently realized that basically what happened is, I followed two different tutorials to "upgrade to 4.0 without breaking homebrew" only to upgrade to 4.0 and break homebrew.

    To answer your questions -- I am using HBC 1.0.3

    First I upgraded with Nintendo. When that gave me the effects enumerated above, I used my BootMii back up to revert to 3.3 and everything worked. Then I used waninkoko. That got me the exact same result. I again reverted to 3.3 by way of my BootMii backup. Interesting note--BootMii wouldn't load on 4.0 either, as it only loads when my SD card is in the slot (even though it's on boot2) and my SD cards didn't work on 4.0

    cIOS rev 9 or 13 for the two upgrades to 4 (I think). Not sure what it's on now...the stock one at 3.3 after using the HackMii installer for my initial modding.

    I did not deliberately explicitly downgrade any IOSes. If any firmware updaters or my BootMii backup restore changed them, then that's how they changed.

    I just wanted 4.0. If I'm all set with 3.3, then so be it. But now, it's about the challenge and the principal of the thing. The tutorial writers wrote great, clear tutorials. I followed them to the letter (I thought...) and did not get the intended result. Did I discover another serial number series that doesn't take well to the upgrade or did I miss something having USB loader installed or not having DVDx installed?



  4. #4
    I think your problem may lie with HBC 1.0.3, I haven't upgraded yet because its too new. Plus I've never had any problems with the older version so why bother to upgrade it only things i've heard is problems so far. I'm not sure you can go back to 1.0.1, that'd be better answered by dogeggs. maybe you can find the HBC 1.0.1 boot.dol, put that in the root and do twilight hack/bannerbomb? I don't know if it will overwrite or not. Its strange that only homebrew will not see the SD card on 4.0. It's possible that HBC may not be the cause if BootMii is doing it too. Did you upgrade your HBC on 3.3 or opn 4.0?

  5. #5
    Upgraded HBC on 3.3

    Actually got a PNY 4.0 GB SDHC card (and my reader/writer does support SDHC) yesterday to be my other brand of card which the compatiblity tests at said should work. It did not.

    So, b/c the wife wanted to play Mario Kart, I restored the 3.3 backup and set it up for us to play...after going through the HBB and installing more stuff like FTPii of course. I remembered reading something about DVDx being a necessity (turns out it's for FTPii I think). So I downloaded it and also some program for file managing on an SD card.

    Short end is this--after doing that (there were about 9 other downloads too...mostly HB games), my 3.3 Wii suddenly could read both SD cards. HBC launched with EITHER of them. BootMii launched with only the one, but I guess that's actually possible. Booting with the one and swapping for the other is ultimately OK with me.

    I'm wondering if now upgrading to 4.0 would yield better results, as now I'm not going in with the same circumstances I had been...

    'Bout to leave the state for 3 days for a friend's wedding. I'll see what more I find here (and what more you have to say my friend) and then ultimately will try the upgrade and post what I find out. It may be that I'm actually in uncharted territory and should log what I'm doing.

  6. #6
    if you delete the hbc 1.0.3 and reinstall 1.0.1 and then upgrade to 4.0 with waninkokos package you will be up fine just dont upgrade to 1.0.3 or the black screen will return

  7. #7
    Sorry to bump an old post, but it is hard to tell if this is resolved.

    I'm experiencing a near identical problem, except instead of the blank screen I get to the Homebrew Channel, with the bubbles, but no apps listed from my apps directory.
    I'm on 4.1U, cIOS38Rev14, BootMiiBeta3, HBC 1.0.3, DVDx from the HackMiiBeta2 installer.

    I've done nearly everything preachercrash has done. I'm using a 2GB microSD card with adapter. (Kingston brand) What's really weird is that I have 3 identical memory cards, and 2 of them work with the HBC, and this one doesn't. BUT, the one that doesn't work with the HBC works in EVERY OTHER way. In my head, I', like WTF? LOL, I TOTALLY can't figure it doesn't make ANY sense to me.

    I've formatted the problem card, and copied EVERYTHING from a working 2GB SD card over to the one causing me problems, and still no luck.

    DOH...just needed to google a little more...
    Found my own answer

    HBC doesn't read my SD Card/it's content

    Had to format the SD card with an SD Formatter:
    SD Formatter
    Last edited by skyknight; 08-22-2009 at 06:45 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts