Results 1 to 2 of 2

Thread: So my recently purchased Wii has firmware 3.0, too late for a modchip?

  1. #1

    So my recently purchased Wii has firmware 3.0, too late for a modchip?

    ???

  2. #2
    No... anything you may have read about firmware is if you want to play backups of gamecube games WITHOUT a chip. For this you need I believe 2.20 or lower firmware. Currently there is no other way to play wii backups than by using a modchip, so if that is your goal it is never too late to chip your wii!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •