Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: How do you make a DVD with ROMs work?

  1. #1

    How do you make a DVD with ROMs work?


    I've been struggling trying to figure out how to get snes/nes roms to load from a DVD. I have several DVD's that load as Gamecube CD's but I'd prefer to be able to use the latest emulators to play my Roms. I burned an NES/SNES DVD where the directory structure is simply:


    Unfortunately, I get an 'Invalid DVD' message. I'm configuring the emulator to load /nes/ I would assume I would get a directory listing but this never happens.

    My Wii also has a modchip..

    Any help would greatly be appreciated.

    If I do find the solution before hand I will post it up to help others

    Thank you..
    Last edited by propho; 05-07-2009 at 11:04 AM.

  2. #2
    Nobody has done this? So everyone is simply using their sdcard for roms? I kinda find it hard to believe that nobody has attempted using a DVD.. I've been searching every day for an answer and find none.. seems like everyone keeps using the premade dvd's which I'm trying to avoid as I would like to use the latest emulators

  3. #3
    i run both snes and sega megadrive roms from dvd and wii64 but thats crap doesnt work right game runs slow but it still runs the emulators have to have a load from DVD option i can,t remember how i done it i will check how i have the dvd structured.I read it somewhere on this site or wiibrew bcos i wouldn,t know how to without detailed instructions.By the way my wii is only softmodded no chip 4.0E

  4. #4
    I just remembered i downloaded both from BTjunkie opened the Rar and burned to DVD then i used the HBC and opened each emulator from there and load from DVD on snes9x the newest one .I'm not sure the structure of the DVD,here is the snes DVD
    Apps folder with the relevant dol files(every dol seems to be here snes9x,megadrive,nes etc)
    BIOS folder with bios (i think this is only for Neogeo )
    config folder with 3 dol files(openwii.dol wiifree.dol yaosm.dol)
    Roms folder with the roms
    hope this helps or just google snes roms dvd

    Just checked the sega megadrive DVD which simply has one folder sgenroms with all the roms in it bin files and i know when i load the genesis emulator change the setting to load from dvd on that folder comes up i think the snes dvd is more complicated then it needs to be i think as long as you have the Rom folder with the snes smc files in it the emulator will find it.I say this bcos when i load the snes dvd thru the snes9x all files but the roms seem to do nothing the emulator gives unknown file or something similar. I did download that multiboot disc with all emus and games but i can't work it,I read somewhere it will only work with chipped wiis
    hope some of this waffle helps
    Last edited by luckydog82; 05-09-2009 at 10:04 AM.

  5. #5
    Okay, tried yet another method and it still will not read the DVD from snes9x, etc. I downloaded BootableDisc3.rar which created a readable DVD which allows me to browse the DVD. So clearly, something else is the issue here with the snes9x program. I don't want to load the snes9x program via the DVD and I want to load the DVD through homebrew->snes9x

    Luckydog: I'm assuming that the DVD you are referring to is loading the emulator off of the DVD right?

    Any other ideas guys?

  6. #6
    I've been trying to get this to work for too long.. moving onto getting it to work over the network =|

  7. #7
    Well got everything working over SMB.. works like a charm.. guess I may drop my attempts at loading off DVD via the emulator through homebrew.. Guess the only choice is to make updated bootable DVD's =(

    If anyone's having trouble with getting SMB working lemme know.. it's real easy..

  8. #8
    i assume you have dvdx, and are setting the emulator to read from dvd. If those two options still fail, try burning them directly to disc, i have SNES goodset on dvd, but all roms are not compressed on the root of the dvd, perhaps folders are no good, but I haven't tried Genesis, That good set ha directories but I don't care for genesis

  9. #9
    No i have the snes9x emulator which i downloaded directly to the wii's sd card from the homebrew browser and the same as the genesis both of these i run from the HBC and each emulator has the load from dvd option.have you DVDx installed as VashTS suggests maybe thats the problem

  10. #10
    Yes, I have downloaded DVDx Installer 3.4 via the homebrew browser and installed it in the homebrew channel. I'm pretty content with loading via SMB.. but of course now I can't load via SMB for Genesis, Turbo GFX 16, and Neo Geo as they don't have this option.. =(

Page 1 of 2 12 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts