Results 1 to 4 of 4

Thread: Just looking for confirmation first - updating

  1. #1

    Just looking for confirmation first - updating

    Running a D2Pro v3 on a D2E drive, wii is 3.3u. Solely running ntsc games and a few have updates. I just want to confirm that a ntsc wii system update is ok on a ntsc wii. The only issues are when you have updated from a PAL game and want to play it on a ntsc system, then you need brickblocker. I have been reading and just want to confirm this before i update from the ntsc disk.

    Thanks for your help.

  2. #2
    Banned
    Join Date
    Sep 2008
    Location
    Michigan
    Posts
    2,236
    Ok, this answer is all over the site but I will answer it because I'm feeling nice today. If you have a modchip you can update to 4.0 or whatever, as long as it is an in-region update. If you cross update we will have to listen to you cry about it later on ;D.

  3. #3
    hahaha, beautiful answer, much appreciated.

  4. #4
    Banned
    Join Date
    Sep 2008
    Location
    Michigan
    Posts
    2,236
    Just thank me if you like what I say ;D lol. xD

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •