I've recently decided to start playing Gamecube games on my Wii again, but after updating to USB Loader GX 3.0r1218 and DM 2.10 whenever I launch a Gamecube game I get the error "Fatal error apploader size is zero."

-USB is 1TB, two partitions with the Wii/GC being first and primary (active if it matters), formatted as FAT32 with 32kb clusters (64 clusters per sector)
-I've come to the conclusion that the .iso of the games are fine, tried them off the SD card with DML and they worked fine.
-Wii is softmodded (bannerbomb if I remember correctly) on 4.3U
-I've tried a combination of USB Loader GX revisions and DM versions but nothing worked.
-I've also tried Wiiflow 4.2 and Cfg Loader v70m51 but got the same error which worries me.

I was going to include a syscheck, but I'm unsure whether I should include it in this post, or in the stickied thread and just link to it or something?

I apologize if this is the wrong section or has been asked too often, I've searched around this forum and another, along with Google but all the answers seem to be the same and havn't worked for me/did not apply.

Any and all help will be very much appreciated!