This is my first post so I figured the Newbie section was appropriate...

Summary of the problem:
My son got Skylanders Giants for Christmas, our Wii's disk drive has been broken for a while so all of the games we own are loaded externally. I've tried two dumps (one .iso and one .wbfs). We currently have no issues playing the existing games on the current set-up:

fw: 4.1U
hb: v1.1.0
d2x: v8 (based on the system check below)
Loader: GX Loader 3.0

Both the .iso and .wbfs dumps show up in GX Loader and when selected load the "splash screen" with the game title graphic in the background and the option to start/configure the game. I've tried the various suggestions (force NTSC, set IOS to 247, 249, etc...) I was able to experiment with a dump of Skylanders Spyro's Adventure this game makes it a bit further to the "Activision" graphic on the load sequence, but hangs there. I was thinking we need to update the Wii the fw 4.3 but wanted to check here first, please take a look at my system check below and make sure I'm not missing something obvious to get these games loaded, thanks:


Also please note I have the following enabled in PriiLoader:
- Block Disk Updates
- Remove Diagnostic Disc Check
- Move Disc Channel
- Block Online Updater