Results 1 to 8 of 8

Thread: Emulator forwarders launch from Wii menu but not from Usb Loader Gx

  1. #1

    Emulator forwarders launch from Wii menu but not from Usb Loader Gx

    I have 3 emulator forwarders that do not launch from Usb Loader Gx v3.0 (IOS249). They do however, work from default the Wii menu (dashboard, not sure what it's called).

    When launched from Usb Loader Gx they get to the loading screens, but then after a couple seconds it goes back to the Usb Loader Gx screen. Other channels on the Usb Loader Gx work suchs as Mii channel, Forcast channel, HBC and the Game backups I have on my usb hdd.

    Are they only compatible with the Wii menu for some reason? Or is there a setting in the Usb Loader Gx I can change in order to get these to work?

    I am thinking the problem might be that they are technically channels and not forwarders, but I am very new to Wii modding so idk.

    Emulators: FCE Ultra GX 3.3.4, SNES9x GX 4.3.2, Genesis Plus GX 1.7.4 (all installed via the Homebrew Browser)
    Forwarders: FCE and SNES were both installed via channel installers from the Homebrew Browser. The Genesis one I got from a forum (sorry don't remember where)

    The items I got from the Homebrew Browser were all installed yesterday so they should be relatively new versions.

    I have the listed prereqs per the readmes for both the FCE and SNES:
    -IOS58, dol in /apps/fceugx/boot.dol or dol in /apps/snes9xgx/boot.dol on my usb hdd

    Any ideas? Thanks in advance.

  2. #2
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Game Master
    cjizzle's Avatar
    Join Date
    May 2009
    Southeast Ohio
    I know you said you have ios58, but have you set each of the problematic channels to load with it?

  3. #3
    Nope, not sure how. I looked through the Usb Loader Gx settings for each channel and found:
    Settings -> Game Load -> Game IOS: tried to change from 'Use Global' to 58 receive error:

    "Invalid IOS number entered, Number must be -1 for inherit or 200 - 255."

    Also, tried emulator channels in WiiFlow it launches directly to black screen. (no load screen)
    WiiFlow's settings allow IOS to be changed to 222 - 251, so no luch there.

    Since the launchers do work work in the default Wii menu it does seem like a usb loader/usb loader settings issue.
    I think I have exhausted the google machine.

    Is there another way to change the ios a channel uses when launched through Usb Loader Gx?
    Or any other suggestions?

  4. #4
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Game Master
    cjizzle's Avatar
    Join Date
    May 2009
    Southeast Ohio
    So try -1. I have never had this issue, but it says right there what you need to do. If that doesnt work we may need to build you a cios based on 58. Pretty easy really, but try entering -1 to see what happens.

  5. #5
    Tried setting to -1 in the Usb Loader Gx still same issue (think it has always been -1 by default).
    After setting the "Game Ios" to '-1' the "Game Ios" value shows 'Use Global' which leads me to believe it inherits from the Usb Loader Gx global setting "Boot/Standard" which is 'IOS 249'.

    Seems like changing "Boot/Standard" to 'IOS 58' might not be the right action, since it was not even a possible selection in the "Game Ios" option.
    Tried setting it to 'IOS 58" anyway and it throws "Warning: This IOS was not found on the titles list. If you are sure you have it installed than ignore this warning", so I am scared to try that because I'm not exactly sure what Ios' are (think there similar to drivers).

    I also tried "Game Ios" set to 'IOS251' since my syscheck shows IOS251[58] but still same issue it goes to loads screen for a couple seconds than back to the usb loader.

    Is IOS251[58] a cios based on 58? If could you tell me how to create one if still neccessary?

    Thanks for your help and sorry if my replies are lengthly and mostly useless. ( me == newb so I dont know what is useful)



    Last edited by KSM0071; 11-27-2013 at 09:25 PM.

  6. #6
    WiiHacks Staff
    Only site donators may send a PM to WiiHacks Staff
    llaffer's Avatar
    Join Date
    May 2010
    Looks like 251 is based off of 58 based on your syscheck. try telling the loader to use that.
    [spoiler=Click Below for recommended Links]

    Download the latest:
    Latest Loaders CFG v70r65
    GX r1226
    WiiFlow 4.2.1
    Other downloads DM/DML 2.11

  7. #7
    I set loader to use IOS251. Still same issue. Each emulator channel launches to load screen for a couple seconds than back to usb loader menu.

  8. #8
    What I have discovered about the emulator forwarders:
    -Launching from wii menu (with app in sd or usb) -> always works
    -Launching from usb loader gx (with app in usb) -> screen goes black, resets to loader menu
    -Launching from usb loader gx (with app in sd) -> launches emulators successfully, but emulators cannot load usb "USB Device Not Found"

    I have tried several different forwarders (even creating some of my own) with various results, but the best results are those above.
    I wish I could create forwarders that would only check usb://apps/[emulator_name]/boot.dol and work for both the wii menu and usb loader gx. Each time I have tried using CustomizeMii to set it to the usb path only, the results are the above at best.

    I wonder if it has to do with me using the 2nd partition on my hdd, but it seems odd since it works from the wii menu.

    So I think I have decided to say screw it and just use the wii menu to launch my emulators.

    Thanks for all your help.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts