Hi Guys!

I am new here and have just recently bought a wii. I'm in all my wits end. I'm trying to softmod my wii for my baby but got these problems.

1. 160GB HD (My old stock) not working on any USB loader.
2. Games not loaded in 1TB USB HD (My old stock) but ok on 8Gb flash drive.
3. Can't transfer .iso file games via wii fusion in mac osx.
I followed the Softmod Any wii guide from MAuifrog (Thanks to his wonderful guide!) for my wii SM 4.3u except to this specific part in Chapter 2 "If you would like to update your Wii IOS:" and the "downgrade to SM4.1 guide". Load same Mario and a dance game both are .wbfs files and less than 4Gb to my 8Gb Flash drive, 160Gb and 1TB HD thru wiiback fusion in MAC OSX.
Then using the FAT32 Guide by Pob3008 (Thanks for this too!) and some the NTFS guide here (Can't find the post anymore) for my MAC OSX 10.6.8.
1 - A. Then I tried to format my Wester Digital 160 GB Model No. WD1600U017-005 to full FAt32, full NTFS, did partitioning for WBFS format but no luck. All the loaders (USB loader, Neogamma, CFG and Wiiflow) I tried doesn't recognized the USB. Wasn't able to successfully format it ti WBFS format from free space due to game loaders can't detect my USB HD. I check the USB compatibility list and didn't find it in there.
B. Is there any work around to make my 160GB HD work on my wii?
C. Found this post from moebius_2033 but I am not sure if anyone has done this? If so, can you please provide a guide for beginners like me?
Here's the link: http://www.wiihacks.com/recommended-...y-list-55.html
Here's some detailed errors:
When formated to NTFS:
- CFG loader IOS56 d2x V8 final mload v1.0:
IOS249 (r21008)
Device not responding! Error! (ret = -1)
- USB loader GX v3.0 r1209:
USB device not found
- Wii Flow 4.1 r436
"I have not found any plugins. Select partition to select your partition type." Then hangs up when "Install Game" then prompts "Disc_wait failed."

When formated to FAT32:
- CFG loader: wbfs error: hd num sector doesn't match
- USB loader Gx: game in list but returns to HBC menu when hit the "start" button.
- Wii Flow: Disc_wait failed

2. I tried using my 1TB WD My Passport Model No. WDBBEP0010BBK-01 , which is also in the compatibility list in NTFS format.
Thru USB loader under settings initialized or something, I can see that the HD is recognized but the games were not detected. Other loader still doesn't work. I tested those games in my 8GB flash drive on fat32 format only.

3. Also, I wanted to test if I can play my .iso files but can't seem to transfer those game files thru wii fusion as an error occurs.

Here's my syscheck in case you need it.



Appreciate all the help I could get as I have been trying to search a lot of threads but seems I can't find anything so far.
My apology if the same questions has been reposted a lot already, just can't seem to find the solutions I need.