Results 1 to 3 of 3

Thread: Dreaded DSI Exception error trying to run any game, could it be a faulty Wii?

  1. #1
    New Member
    Join Date
    Nov 2009
    Thanked 0 Times in 0 Posts

    Dreaded DSI Exception error trying to run any game, could it be a faulty Wii?

    Ok, I just want to say a few things first so perhaps the more knowledgable members don't just dismiss this plea for help because its likely they are the only one who can help me

    I've been a member of this board for quite some time and have had little need in the past to call on help.
    I have hard modded and soft modded quite a number of Wii's over the years, so I'm pretty sure I'm not missing something silly.

    So, without further a-do:
    I have a Wii I softmodded for a friend about a year ago which is now coming up with a DSI Exception error the minute you select a title to play from WiiFlow.

    When I configured this (and other Wii's), I did the full monty, including preventing online and disc updates to make sure they couldn't mess up their systems inadvertently.

    I've also been setting up HDD's with a two partition type configuration to relinquish the need for an SD Card and hence rule out possible SD Card issues.
    E.g. a FAT32 for the USB Loader and associated tools and an NTFS partition for all the wbfs files.

    I use a Wii Forwarder channel to load up WiiFlow from the FAT32 partition of the HDD.
    I have tested the HDD on another softmodded Wii and the titles load up fine using the same WiiFlow installed on the FAT32, so I think that proves that we can eliminate the HDD as a possible cause of the problem.
    To double down on this assumption, I have also tried the HDD from my own Wii on this system and the same DSI exception errors occur when trying to launch a game.

    Left with the physical Wii unit as being the probable cause of the problem and the fact that I'm not using an SD Card, it has to be something screwy with the IOS, CIOS right?
    Knowing the typical users of this particular Wii, its highly unlikely it has been messed with from a techy point of view. I even hide the HBC away on the end screen and with no SD Card, even if found, the users can do very little.

    Despite this knowledge and out of desperation, I have gone through and re-applied all the softmod hacks using my old original method and using newer methods of batch installing but to no avail.
    I even reluctantly erased the system memory yesterday because I'm all out of idea's

    So unless anyone has any bright idea's, I am left wondering whether this Wii has suffered some sort of fault thats causing the DSI Exception errors. Its not a thought I'm completely comfortable with, more of a desperate theory due to all the facts mentioned above, Grrrr.
    Last edited by drh; 11-28-2012 at 01:36 AM.

  2. #2
    New Member
    Join Date
    Nov 2009
    Thanked 0 Times in 0 Posts
    Ok, finally sorted it myself, but this was a really weird problem that was not consistent across multiple Wii's and HDD's!!

    I will briefly explain why this sent me around in circles in case it helps anyone else out in future, but it is still quite baffling!

    Basically, it seems something was screwed in WiiFlow but (and this is an important BUT), the WiiFlow installation on the FAT32 partition did still work on another Wii, hence me dismissing the HDD and WiiFlow installation as being a potential culprit.

    As I said in my first post, I did put the HDD on an old spare Wii I had lying around and everything loaded up fine. Put the same HDD back on the problematic Wii and it would crash, this led me to believe it had to be the Wii that was the problem.
    Another thing that compounded this thought was I did try a newer WiiFlow but that just crashed with a DSI Exception before it even got to the games carousel.
    A final attempt today to try WiiFlow 4.04 with a fresh set of settings files worked and led me to enlightenment, although I still can't explain why the old WiiFlow installation worked fine on a different Wii (and did work on the original Wii for 12+ months) !?!??!?

  3. #3
    New Member kunparekh18's Avatar
    Join Date
    Sep 2012
    Thanked 145 Times in 118 Posts
    Probably different region/system menu settings that did not match up between the Wiis. Anyway, glad to know you solved your problem. Moderator, thread close please!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts