The wii is my first venture into console modding. I first used letterbomb while I learned how to do it but in the end it wasn't correct as well as I knew how to do it. So I redid everything with modmii. I think it's all set up pretty much correct now. I have a bunch of apps and emulators working fine. One problem though that I have had since I started is that the loaders can't seem to connect to my HDD. It's a western digital 80g FAT32 formatted drive in a simple enclosure connected through usb of course. Every time I load up usb loader x or CFG my HDD read/write activity turns off. The loader lags as if it is trying to read the drive but then eventually times out. When it's plugged in an on the process of the loader is very long so I can tell it's trying to do something. Because when it's off/not pluuged in/plugged into the incorrect usb the loader times out very quickly. I have 2 games on the HDD via backup manager which seems to work great, backup manager that is. At this point I'm guessing it's a problem with an IOS(totally newb to this and still not sure what these even are) or the HDD isn't compatible even though others seem to be able to use similar HDDs. I have tried a lot of tutorials and troubleshooting guides but just can't figure it out. I ran syscheck from the wiibrew download and it crashes at the end, maybe because it's outdated? I downloaded and installed syscheck GX from the homebrew browser and it produced this.