Results 1 to 10 of 10

Thread: Black screen on SNES and NES emulators.

  1. #1

    Black screen on SNES and NES emulators.

    Hello there. I know there are many topics on here, but I can't seem to find the answer I'm looking for.

    I recently softmodded my Wii console with Homebrew and Bootmii. Bootmii was installed as iOS because it couldn't be installed as boot2 (maybe that will be of some help).

    Everything went smoothly. I tried playing some ROMS for the SNES emu (snes9x GX) to no avail. I get a black screen with sound but no video when I start the rom. I can hear the game sounds and nothing locks up. The only problem is that I can't see anything on the screen. The N64 emulator wii64 works perfectly (the sound messes up a little but that is to be expected). Any help would be much appreciated. Let me know if you need more info.

    Thanks in advance.

  2. #2
    New Member miihackwii's Avatar
    Join Date
    Jan 2009
    In the settings of the emulator, you will have the option to force pal or ntsc try using one of those options to correct your problem.

  3. #3
    How would I even get to the settings? The only settings I can get to for the SNES and the NES are the Homebrew settings. I assume those are the emulator settings however none of those options that you listed are available to me. The only ones listed to me are 'network', 'saving & loading', and 'menu' settings.

    I should also like to mention (as to maybe clarify further) that once I start the rom I can't even get to the Wii menu's (pressing the HOME button on the wiimote, etc). I can hear the menu's, the controller vibrates, but I can't see anything.

    I would also like to mention I'm using an actual SD card. It's not Sandisk, but if it can read n64 games then I don't see why it wouldn't play other emulators games. Although I could definitely be wrong, each emulator and system is completely different.

    Thanks for your reply, and thanks.
    Last edited by Nightgaunt; 10-31-2012 at 08:55 AM.

  4. #4
    New Member miihackwii's Avatar
    Join Date
    Jan 2009
    are you using snes9x gx for your snes emu? if so here is a picture of the screen you should get. the video settings are under "video"

  5. #5
    I don't have the Video or Button Config options on my emu screen.

    That's actually really weird. Does it mean I've installed the softmod wrong? As far as I know that was the newest version of Hackmii and Homebrew. As well as the latest SNES emulator version. I could definitely be wrong. Would pictures help?
    Last edited by Nightgaunt; 10-31-2012 at 12:41 PM.

  6. #6
    New Member miihackwii's Avatar
    Join Date
    Jan 2009
    Your softmod will be fine mate, download and install the latest snes9x gx emulator version 1.53 from wiibrew.

  7. #7
    1.53? I don't understand. The latest version is 4.3.1 for the SNES9x gx. I just downloaded from the wiibrew website. Still no video or controller config options. Just 'saving and loading, network, and menu.

  8. #8
    I know what you mean. I'm having the same issue. I downloaded and installed homebrew without a hitch, but when i click on any of the NES or SNES roms the screen just goes black and my TV says "no signal". ????

    I have 4.2.9 of SNES9xGX, and it keeps trying to update, but then says "updated failed". The NES emulator downloaded and installed an update successfully but it still doesnt work. Once I get some N64 and MAME roms ill try those, but I dont understand why its not loading....?

    I'm going to work on this, but if anyone can offer any help in the meantime it would be much appreciated.

  9. #9
    I had the exact same issue. This is definitly related to a PAL/NTSC issue, and the newest version of snes9x for wii removes the video option in the menu. Fortunetly, after a bit of digging, I found the fix.

    Insert your SD card into a PC and browse to \apps\Snes9xGX. There, you'll find a file called "settings.xml". Open it and locate the "video" section, then the "videomode" setting. Change the value from "2" to "1". Save, then inset in your Wii and load again.

    Hope this helps others who stumble upon this!

  10. #10
    WiiHacks Staff
    Only site donators may send a PM to WiiHacks Staff
    llaffer's Avatar
    Join Date
    May 2010
    This thread is 14 months old. Closing it...
    [spoiler=Click Below for recommended Links]

    Download the latest:
    Latest Loaders CFG v70r65
    GX r1226
    WiiFlow 4.2.1
    Other downloads DM/DML 2.11


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts