For a long time now I have had my WII set to play videos off my USB via Mplayer-ce. I've never had any real problems with this setup that I couldn't figure out after a few minutes of browsing the internet, but this time I can't seem to find anything that works, nor can I think of a reason why it isn't working.

This morning, I woke up and started up Mplayer to play some videos. since I don't have TV I do this everyday. It worked fine, no problems until I had to turn it off to move some new videos from my computer into the USB drive. Once I plugged it back in, I noticed Mplayer saying there was no drive mounted. I get that sometimes, so I unplug the USB drive again, and wait a while before trying it again. It doesn't work. After a while of trying this, I try accessing the USB with another app, WiiXplorer, and it doesn't show up there either.

So far I've tried installing/reinstalling some cIOS that are supposed to fix similar issues, but nothing has worked. Any help would be greatly appreciated.