I recently updated my softmod on my 4.1U Wii and my copy of Twilight Princess that I ripped onto my USB drive no longer shows my saved game! I have the save showing up in the Wii's memory, but not in game.

Here are the things I have tried so far;
I booted up with the original disc and no joy,
I copied the save from the Wii to SD and then began a new game, saved it and quit then loaded the original save from the SD card. Nothing.
I took the 'private' folder for the game and transferred to my PC then created a new save and then manually put the data.bin file into the new folder and put it back on the Wii. Again nothing.
I also tried using partial and full emulation in wiiflow and that just caused the wiimote to disconnect and then I got the same result when starting the game. I'm at my wits end here! Please help. I have googled and searched, nothing seems to work so far what am I not doing? Yes this is a rip from my original game disc and it is NTSC as well as the save is from my original game.