Hi everyone,

I soft-modded a friend's wii about two years ago, using a tutorial from wiihacks (was a SD exploit IIRC). Worked fine, told my friend to never update it for whatever reason, you know the drill. So of course, he updated about 8 months ago, as he had bought the UDraw tablet with some game for his daughter, breaking the softmod in the process. He claims he was still able to play game disks, although the USB loader was gone.

Now, he brought me his wii a few days ago so that I could soft-mod it again. I didn't try to plug the wii while he was there.
The thing is, it won't even turn on: The power led is red when I plug the wii, but pressing power, or any combination of Power/Reset/Eject won't do anything. When I try to insert a disk, the drive won't accept it. The led just stays red.

I'm almost certain the issue isn't with the AC adapter, as it is the one I use for my own wii, which works fine (I checked!). My friend brought me his wii with no AC adapter or wiimotes, since I wasn't supposed to need them (silly me). As is, it is as usefull as a brick with a power cord, but is it a brick in the usual sense, I am not sure. I haven't tried to power the wii with a synchronized wiimote, because I don't have one, although I have access to a GC controller if needed. I don't think it will help anyway since the wii won't even try to accept a disk.

So is it a brick? If it is, can someone help? If it isn't, well, this does not belong to the "Bricked Wii Issues" forum, so where should I look for a solution?

Thanks to anyone who can offer advice or help about the issue.