Results 1 to 1 of 1

Thread: DStwo new firmware V1.16 Released, support 3DS V4.2.0-9

  1. #1
    New Member dsflashcart's Avatar
    Join Date
    May 2012
    Thanked 68 Times in 56 Posts

    DStwo new firmware V1.16 Released, support 3DS V4.2.0-9

    As we know that 3DS firmware has been updated to V4.2.0-9. and the new firmward has been confirmed to block flashcarts. Today DStwo official site has released a new firmware to make their supercard dstwo card work on the latest 3DS V4.2.0-9. good job, DStwo team. So if you own a DStwo card, just feel free to update your DStwo with a DS console which can run the latest EOS. If you plan to buy a DStwo flashcart for your 3DS V4.2.0-9, just remember to buy a preflashed one which you don't need to update it when you receive it.


    DStwo latest firmware V1.16

    DStwo EOS V1.11

    Currently there are two cards support 3DS V4.2.0-9, R4i gold 3ds (official site: and DStwo card. here is the real DStwo: There are also one or two other cards have been confirmed working, but i really dont recommend people buying them, so i didnt mention them.
    Last edited by dsflashcart; 07-05-2012 at 05:20 AM.
    Do yourself a favor, don't buy crappy flashcarts.

  2. 1 User Says Thank You dsflashcart For This Useful Post

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts