can you still do all the stuff you posted if you have version 3.4e if not how would you go abt downgrading to 3.3 has i am unable to get the hbc on