I have a wiikey 1 and am on 2.2 firmware. Should I update my wiikey to 1.99?