Hi Guys, Pls help me too. I am confuse now. Now i am using Wasabi mod with 3.1U, and most of the newer games cant launch.

1. Does it means i must update my wii via system update inorder to play...