looking for downgrade from 3.4 to 3.3