Results 1 to 2 of 2

Thread: Canadamod Support

  1. #1
    Junior Member
    Join Date
    May 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Canadamod Support

    Okay, I bought a d2pro9 with wiiclip from Canadamods at the beginning of June. I got it and installed and it was working fine up until a week and a half ago. First sign was the disc wouldn't eject and I finally had to take it apart to get the disc out but only after the drive stopped spinning completely, even after power cycling it many times. Finally after repeated disassemblies and reassemblies and testings, when the mod chip is snapped on, the disc drive doesn't power up, doesn't spin, doesn't accept discs, etc., but when the chip is off, it works fine. So it's obvious to me that the chip is defective and needs to be replaced.

    So I'm trying to contact Canadamods but I'm not having any luck. I sent an email to the canadamods@gmail.com and after a week of no response, I sent an email to sales@canadamods.ca which is on their website (since they don't list a tech support or customer service email address) and that was at the beginning of the week and still no response. I can't seem to find a phone number on their website or in the emails. Does anyone know any alternate methods of contacting them so I can return my chip and get a working replacement? Thanks in advance.

    Jeff

  2. #2
    Member
    Retired Staff Member

    Join Date
    Jun 2008
    Posts
    1,494
    Thanks
    70
    Thanked 230 Times in 116 Posts
    You might want to send a Private message to memeber Spyman who represents CanadaMods -> http://www.wiihacks.com/private.php?do=newpm&u=9182

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •