Results 1 to 2 of 2

Thread: Do the Wii games need certain firmware to play?

  1. #1
    Junior Member
    Join Date
    Sep 2007
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Do the Wii games need certain firmware to play?

    I've heard the latest Official Firmware downloads can brick a modded Wii but the latest Wii games need the latest firmware to play?

  2. #2
    Member sziklassy's Avatar
    Join Date
    Aug 2007
    Posts
    283
    Thanks
    0
    Thanked 4 Times in 3 Posts
    If you update the firmware that coincides with your version of wii (ie ntsc wii gets ntsc firmware) you will be fine. just don't update on your NTSC wii off of, say a JAP or PAL disc.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •