Results 1 to 10 of 10

Thread: New Guy with a successfully modded Wii!!

  1. #1
    Junior Member
    Join Date
    Jul 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    New Guy with a successfully modded Wii!!

    Hi Guys, I a new guy who have gotten my Wii for about 3 weeks now. And have been joining this forum for about a week. After alot of reading and searching in this forum, I was able to successfully mod my Wii with all the information provided here. First post here! Thank you for all your help! This forum was great!

    Here is my story:
    Three weeks ago I accidently walk pass Costco and got my Wii. Then I searched around and found this forum for how to hack the Wiis. With the help of posts here, without opening up my Wii, I was able to identify that I have a D2C2 Wii. So I go ahead and ordered the D2PRO9 version 2 from mod chip central. I heard stories that the Wiiclip may be lose for some users, so I didn't order that. Modchip central were really quick in taking order and ship me the chip the same day I ordered! Thanks! However, it still took about 5 days to receive the chip, so I guess it take some time to ship from Canada to California. The chip arrived with the green sticker on it that says D2C2 compatible, so they did ship me the right stuff.

    Then the next thing is to open up my Wii and install the mod chip. I follow the video from youtube named "how to dis-assemble your wii" (something simular) and opened up my Wii. I was very caucious in opening up my Wii and worried that I may not be able to put it back together because there are so many different kinds of screws that the Wii is using. I heard story from one of my co-worker that he has 2 extra screws that he doesn't know where is it belongs. So I first draw a picture of the Wii and with every screw that I've taken out of the Wii, I used the scotch tape to tape it onto the corresponding slot in the picture. This has worked really well for me. Now I have opened my Wii twice and never have any problem putting it back. Then I carefully removed the 2 cables and bring my drive to work so that my friend at work can mod it for me.

    The modding part wasn't that hard. It only took my friend 1/2 hour to mod it (see picture). However, I have to mention that my friend was a professional board technician. Although I did some soldering before, I don't think I can mod it without breaking any wire or anything on the board. I went home, plug back in the flat cable and the ribbon cable, and viola, it still works with my original game-- Mario Galaxy. So I eject it, and put in a copied Resident Evil 4, then another original game-- Wii Sport..Ahah, so it looks like everything played fine and it's getting late at night, then I put the Wii back together. Thing started to go downhill...

    I started really playing a backuped RE4 for 15 minutes. But when I press the eject button, it just eject and drop my disk because the drive motor keeps on spinning even after the disk is ejected half way. Then the next day, I can't insert or eject without resetting or power down. I updated the firmware to 1.4, but no help. Then I opened up my Wii again thinking that I may have a bad connection from the flat cable. But things get worse, after I checks the flat cable and reconnect it back, I wasn't even able to eject my disk anymore, not even after reset or unplug the power cable. Then I searched and saw a picture by "littlejohnny" (posted by GMODZ, thanks) that adds another wire to increase the ampere on the board that may fix the DRE or eject problem, so I gave it a try. That night I went home, carefully plug in the flat cable and the ribbon cable and this time thing justs works! The disk started spinning again once power on. I checked the d2pro website and see that they have a 2.0 firmware that fixes the eject problem, so I burned the ISO using a DVD+RW disc. After updating the firmware using the DVD, now I don't see any eject or DRE issue anymore. So it seems like I have a fully working Wii now! I don't know whether littlejohnny's fix actually fix the DRE/eject problems or not, but it didn't make thing worse. In fact, I was able to eject the disc after adding the fix (before upgrading the firmware). I guess the combination of littlejohnny's fix and the firmware works best.

    So far, I have only 1 fail burn disc-- SSBB using Nero. But when I re-burn it with Imgburn with layer break, it played perfectly. I used TDK+R 4x with Nero for the single layer games and TDK+R 2.4x with Imgburn for the DL games and everyone of them works!

    The following backup games all worked for me:
    SSBB
    RE4
    RE Umbrella Chronicle
    Mario & Sonic at the Olympic Game
    Kung Fu Panda
    DECA Sports

    My Wii: LU547 D2C2 with d2pro9 v2
    Wii Firmware: 3.3u
    D2PRO9 Firmware: 2.0

    Thank you everybody for your help! Happy to join the forum.
    Attached Images Attached Images

  2. #2
    Inactive *********
    *UNDERSTAFFED*ONLY MK Contestants & ***** Supporters can PM MODS
    jebise101's Avatar
    Join Date
    Jun 2008
    Posts
    425
    Thanks
    0
    Thanked 16 Times in 7 Posts
    wow you have a lot of time on your hands to write all that. But glad that you got everything working

  3. #3
    Member
    Retired Staff Member

    Join Date
    Jun 2008
    Posts
    1,494
    Thanks
    70
    Thanked 230 Times in 116 Posts
    Yeah, well done !!! Besides the soldering the hardest part is opening and putting the wii back together

    By the way what is that Yellowish tape that you have on the drive? it that electric tape?

  4. #4
    Junior Member
    Join Date
    Jul 2008
    Location
    The Netherlands
    Posts
    27
    Thanks
    9
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by jbloggs View Post
    Yeah, well done !!! Besides the soldering the hardest part is opening and putting the wii back together

    By the way what is that Yellowish tape that you have on the drive? it that electric tape?
    its a special one called Kapton tape, used by Techy people.

    its very expensive per roll but it works perfectly, very thin, none conductive.
    i use it all the time.

    Btw, nice post

  5. #5
    Junior Member
    Join Date
    Jun 2008
    Posts
    51
    Thanks
    0
    Thanked 3 Times in 2 Posts
    Quote Originally Posted by valkait View Post
    I checked the d2pro website and see that they have a 2.0 firmware that fixes the eject problem, so I burned the ISO using a DVD+RW disc. After updating the firmware using the DVD, now I don't see any eject or DRE issue anymore.
    Umm sorry to say but you never updated the firmware. The dvd update is only for the spi-flash (minor updates) if you wanted to update the Actel chip to 2.1 (not 2.0 D2pro guys made a mistake) you need a D2prog along with that flat ribbon cable to connect via usb to your pc to update it and fix the "eject issue". I know it sucks...just found this out my self. Good thing that other fix worked cause I guess their having issues with the 2.1 firmware and D2C2 chipsets. Its not recommended to update......yet d2pro : News

    Just a FYI this boards peeps are not very nice or helpful
    Last edited by dingchow; 07-19-2008 at 07:12 PM.

  6. #6
    Junior Member
    Join Date
    Jul 2008
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    hi guys i'm new on this wii ting i had my wii chipped with d2c and don't play all the home brews copies i just did it 2 days ago any idea if after the d2c install i need to do any ting after modding it please help.went insert the home brew game star doing an up date by it self got scare and stopped from continue scare it may get brick.
    Last edited by paisa; 07-19-2008 at 10:20 PM.

  7. #7
    Inactive *********
    *UNDERSTAFFED*ONLY MK Contestants & ***** Supporters can PM MODS
    jebise101's Avatar
    Join Date
    Jun 2008
    Posts
    425
    Thanks
    0
    Thanked 16 Times in 7 Posts
    paisa i have no idea what you are talking about, d2c is not a modchip but wii drive d2ckey, d2pro9, wasabi are modchips, when you say homebrew copies do you mean backups? because the term homebrew mean codes made for the wii by egualar people.

    P.S i would recommand you start another thread with your question

  8. #8
    Junior Member
    Join Date
    Jul 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by jbloggs View Post
    Yeah, well done !!! Besides the soldering the hardest part is opening and putting the wii back together
    Yeah, taping it makes it much easier.

    Quote Originally Posted by jbloggs View Post
    By the way what is that Yellowish tape that you have on the drive? it that electric tape?
    Yes it is. It prevents the wires from getting lose.

  9. #9
    Junior Member
    Join Date
    Jul 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by dingchow View Post
    Umm sorry to say but you never updated the firmware. The dvd update is only for the spi-flash (minor updates) if you wanted to update the Actel chip to 2.1 (not 2.0 D2pro guys made a mistake) you need a D2prog along with that flat ribbon cable to connect via usb to your pc to update it and fix the "eject issue". I know it sucks...just found this out my self. Good thing that other fix worked cause I guess their having issues with the 2.1 firmware and D2C2 chipsets. Its not recommended to update......yet d2pro : News

    Just a FYI this boards peeps are not very nice or helpful
    So I got confused about this "utility" and "firmware" thing. To rephrase, I downloaded the "1.5 utility disc" from d2pro, burn it, inserted it into my Wii, upgrade and now my disc eject issue is gone. I don't know what this "utility disc" do to my Wii, but now my Wii works perfectly with both original or backup disks. So maybe littlejohnny's fix does all the hard work? I don't know.

    Sorry if you don't find this board pic helpful. My original picture was much better, but I think there is a limit for picture size on this board.

  10. #10
    Member bumper44's Avatar
    Join Date
    Aug 2008
    Location
    America the Beautiful
    Posts
    349
    Thanks
    42
    Thanked 28 Times in 10 Posts
    wow i am impressed that you already modded your wii i haven't even modded my wii yet!
    Nice job!
    What doesn't kill you only makes you stronger.
    Screw the Whales! Save the Shrubs!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •