Results 1 to 3 of 3

Thread: Help!! I broke my Wii Wii!!

  1. #1
    nmn
    nmn is offline
    Junior Member
    Join Date
    Dec 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Help!! I broke my Wii Wii!!

    Ok so here's the deal.Today I go to put my sister sd card in the my Wii to see some pics. and it click off!! and now in order to get it to turn on I have to unplug it and then plug it back in. The red power light will come on but as soon as I press the power button to power it on it goes dead again. And I have to unplug it again.

    Anybody know what it can be?

    Is there a reset button that I don't know about.
    I've left it unplugged for about an hour but when I plug it back in it does the same thing.


    Model no. RVL-001

  2. #2
    Banned
    Join Date
    Sep 2009
    Posts
    9
    Thanks
    0
    Thanked 2 Times in 1 Post
    Here's a couple random questions

    Do you have plugged into a surge protector/suppressor?
    Have you modded your wii i.e. homebrew or modchip?
    Have you contacted nintendo?
    What kind of SD card was it?
    How old is it?

  3. #3
    Senior Member
    DA KINE WiiHacker
    mauifrog's Avatar
    Join Date
    May 2009
    Posts
    9,168
    Thanks
    307
    Thanked 9,560 Times in 2,969 Posts
    Blog Entries
    15
    I would try another outlet.
    Ipsa scientia potestas est.


    Warning: Piracy is NOT supported. Word your questions carefully.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •