Page 1 of 33 12311 ... LastLast
Results 1 to 10 of 327

Thread: Problem: Wii Remote Plus combined with Homebrew Apps not working.

  1. #1
    New Member TheInfamousTheft's Avatar
    Join Date
    Nov 2011
    Posts
    58
    Thanks
    10
    Thanked 46 Times in 18 Posts

    Exclamation Problem: Wii Remote Plus combined with Homebrew Apps not working.

    How do I get my new controllers to work with homebrew?
    - Each homebrew application has to be recompiled with the latest libogc SVN to work with the revised Wii Motion Plus controllers.
    - Popular Wii homebrew applications updated to be compatible.




    Why Isn't My Wii Remote Plus Working?

    - Read this

    What Types ARE NOT Compatible with DATED Homebrew?
    - Any Official Nintendo WM+ controllers purchased around late November 2011 and on could be incompatible.
    - Third Party Wii Remotes.

    What Types ARE?

    - Regular Wii controllers without motion plus built in.

    - Wii Motion Plus controllers purchased before November 2011.

    How Can I Identify these New Wii Plus Controllers?
    - The most accurate way to identify the new controller is by connecting it to a computer.
    • An old Wii-mote Plus will read as an RVL-CNT-01 when connected.
    • The new non-homebrew working one will read as an RVL-CNT-01-TR.

    - Another way is to look at the code in the battery compartment.
    • Look for a code that says LMB-RVL-WR/ (or something very similar) in small lettering.
    • If it's followed by Z-C4, Z-C6, C-C4, or C-C6 it will not work with homebrew.
    • If none of this applies to your controller, then it will work with all types of homebrew.

    - There's currently no way to identify these controllers by looking at the box.

    Other Details
    - Old/New Wiis and updates do not matter, the remote will not work with any of them.
    - The new revision applies to all Europe, US, and Japan remotes.
    - Certain bundles hold compatible Wii controllers.
    Last edited by TheInfamousTheft; 07-30-2012 at 08:57 PM. Reason: LAST UPDATE: I'm done updating this thread.


  2. #2
    New Member
    Join Date
    Feb 2010
    Posts
    138
    Thanks
    19
    Thanked 17 Times in 15 Posts
    My wii motionplus works just fine. did you say that you updated your wii, through nintendo server? for what reason? 4.3 was just for anti-piracy check by nintendo. bad idea.

    oh and is it just me or you haven't soft modded your wii using a guide here? (softmod guide by mauifrog perhaps?) you have a lot of stubbed important IOSes, IMO.

  3. 1 User Says Thank You gamer89420 For This Useful Post


  4. #3
    New Member TheInfamousTheft's Avatar
    Join Date
    Nov 2011
    Posts
    58
    Thanks
    10
    Thanked 46 Times in 18 Posts
    I used Mauifrog's guide when my Wii was 4.2, but back then my Wii Remote Plus didn't work. So I did a Wii system update to 4.3 (which I found was safe to do, according to the internet) scrub everything of mods and do a cleaner install. That went really well and I updated my Homebrew Channel to IOS58 figuring that would change something. It didn't.

    Anyway, I reinstalled the cIOSes (only to make my USB Loader games work) but not the patched IOSes which is why you saw stubs in the previous syscheck log. So today, I've patched the IOSes with Mauifrog's wads just to see if it would make a difference. Nope.

    The current stubbed IOSes in the current syscheck log aren't important, so there's no need to worry about those.
    Last edited by TheInfamousTheft; 11-30-2011 at 08:30 AM.

  5. 1 User Says Thank You TheInfamousTheft For This Useful Post


  6. #4
    Senior Member Shift_Lock's Avatar
    Join Date
    Dec 2010
    Location
    The City of Rain
    Posts
    5,932
    Thanks
    1,320
    Thanked 1,394 Times in 1,030 Posts
    Blog Entries
    2
    There was anther user having the same issue.. his remotes would not sync until the game launched.. Dont think we ever found the issue or solution.. mine work fine.. not sure what the deal is..

    Did I come off like a jerk?? Read more here


    [/spoiler]

  7. 1 User Says Thank You Shift_Lock For This Useful Post


  8. #5
    New Member TheInfamousTheft's Avatar
    Join Date
    Nov 2011
    Posts
    58
    Thanks
    10
    Thanked 46 Times in 18 Posts
    I got a stupid theory. I'm kinda wondering if this has to do with newer wii controllers using different software that isnt recognized by the homebrew app. Because when I was searching to fix this I noticed most threads about this problem started around November and October (probably because of the release of Skyward Sword).
    Last edited by TheInfamousTheft; 11-30-2011 at 03:04 PM.

  9. 1 User Says Thank You TheInfamousTheft For This Useful Post


  10. #6
    Senior Member Shift_Lock's Avatar
    Join Date
    Dec 2010
    Location
    The City of Rain
    Posts
    5,932
    Thanks
    1,320
    Thanked 1,394 Times in 1,030 Posts
    Blog Entries
    2
    I just recently bought 2 new moton plus controllers that work fine with hbc and apps.. I was kinda thinking the older wii's have issues with the new motion plus remotes..

    Did I come off like a jerk?? Read more here


    [/spoiler]

  11. 1 User Says Thank You Shift_Lock For This Useful Post


  12. #7
    New Member TheInfamousTheft's Avatar
    Join Date
    Nov 2011
    Posts
    58
    Thanks
    10
    Thanked 46 Times in 18 Posts
    Quote Originally Posted by Shift_Lock View Post
    I just recently bought 2 new moton plus controllers that work fine with hbc and apps.. I was kinda thinking the older wii's have issues with the new motion plus remotes..
    That's a better theory than mine. I got my Wii back in early/mid 2007. Then I soft modded it in early 2010, however I never had the chance to use a Wii Plus Remote with it until Skyward Sword came out.

    I've rid of the inconvience of switching controllers in Skyward Sword by setting up a forwarder channel to the game by itself by using the program "Crap". That has been a really good work around for launching USB Loader GX games using my Plus wiimote.

    But I would LOVE to solve the problem in the homebrew area. I don't think comparing SysCheck logs is going to help. I might have to do a little research on Wii model revisions so I can pin point what is causing this.
    Last edited by TheInfamousTheft; 11-30-2011 at 03:20 PM.

  13. 1 User Says Thank You TheInfamousTheft For This Useful Post


  14. #8
    New Member Grandpa1959's Avatar
    Join Date
    Aug 2009
    Location
    Birmingham,England
    Posts
    540
    Thanks
    191
    Thanked 119 Times in 104 Posts
    Hi TheInfamousTheft interesting comments, I have been modding for a couple of years now, I have never had any problems using motion plus with HBC or any part of the mod process, Dogeggs, Shadow sonic or Mauifrogs, or Letterbomb, I am using the two piece type of wiimotion plus controller, My CFG, GX, Neogamma backup loader, HBC all work fine. I see you are running your cios a little different to me but it is only my Cios Base numbers, I am also running d2x alpha7.
    keep us posted if you get to the bottom of this strange anomally.

  15. 1 User Says Thank You Grandpa1959 For This Useful Post


  16. #9
    New Member TheInfamousTheft's Avatar
    Join Date
    Nov 2011
    Posts
    58
    Thanks
    10
    Thanked 46 Times in 18 Posts
    I'm out of ideas of easy ways to fix this.

    So I'm thinking it's one of the IOSes that's below the 200s. I'm not that experienced with the details of IOSes, so I wouldn't know which one to check out and reinstall.

    There's small chance that it's the hardware in the Wii or Wii remote. I don't see any changes to the console's hardware ever since the Wii was released except for the newest one doesn't have Gamecube compatibility.

    I've noticed people having trouble with third party wii motes in HBC, so maybe a Wii Remote in general could be the cause and not the Wii itself. I'm using the official Wii Remote Plus - Black.



    Anyway back to searching Google and I'm finding some interesting things. Seems like the Dolphin emulator has a problem with newer revisions of the Wii controller plus which have seemed to come out less than a month ago. I guess that would also mean that homebrew could be affected by this.

    Dolphin Issue 5011: Wii Remote Plus Does Not Work

    So I believe that the new revisions to the Wii Remote Plus will not work with any homebrew until a fix has been made to the Wii console.

    CASE SOLVED
    Last edited by TheInfamousTheft; 12-01-2011 at 12:36 AM.

  17. 1 User Says Thank You TheInfamousTheft For This Useful Post


  18. #10
    New Member TheInfamousTheft's Avatar
    Join Date
    Nov 2011
    Posts
    58
    Thanks
    10
    Thanked 46 Times in 18 Posts
    Now I just got to wait and see if a fix is figured out.

  19. 1 User Says Thank You TheInfamousTheft For This Useful Post


Page 1 of 33 12311 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •