Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Informational: Effects of The 3.3 / 3.4 Firmwares

  1. #1
    e39
    e39 is offline
    Member
    Join Date
    Dec 2008
    Posts
    1,029
    Thanks
    15
    Thanked 1,340 Times in 187 Posts

    Post Informational: Effects of The 3.3 / 3.4 Firmwares

    Firmware 3.3
    Released: June 18th, 2008

    The problem:
    When a game is finalized by the publisher, it is security signed. The Wii looks for the signature as a part of its authentication check when booting a game. The 3.3 version prevented "trucha" (fake) signed discs from running.

    The details:
    What does this mean? Games that are "fake signed" are often .ISO images modified for various reasons. They're also very prevalent on Torrent sites.

    "Scrubbed" - A game publisher needs to make their title exactly 4.37 GB or 4,699,979,776 bytes (exception being Super Smash Bros. Brawl). Not every game will be of this exact size, so empty / dummy data blocks are placed on the disc as fillers. Wii Scrubber is an application that will remove dummy blocks from the game, thus making it a smaller file to transfer.

    "RegionFrii" - Wii games are Region specific. This application will change the region code of a .ISO game image so it's playable on any of the 3 consoles (NTSC-U, NTSC-J, PAL)

    "BrickBlocked" - This is the removal / patching of a game's disc embedded update. This is a safety to prevent mixed region updating, thus saving your console from a firmware brick.

    As you can see, fake signed games are useful and most likely already in your library. By using the 3.3 firmware, you might render previously working games, useless.

    The solution:
    If you already have the HomeBrew Channel installed, install the IOS51 / Shop Channel fix.

    If you do not have the HomeBrew Channel installed, please follow this guide:
    http://www.wiihacks.com/faq-guides-t...atutorial.html

    You will be downgrading to the 3.2 firmware, along with installing many useful applications such as Wad Manager and StarFall. This is highly suggested.

    3.3 Notes:
    Do you have to downgrade? The answer is "no". If your backups are 1:1 copies with no alterations, they will still play. If you're not interested in the Wad Manager and installing channels to your dashboard, "no".


    Firmware 3.4
    Released: November 17, 2008

    The problem:
    When Nintendo issues a firmware update, they prompt the user if they'd like to install it. A part of the 3.4 user agreement is longer being prompted permission. When a 3.5 is released, it will get installed without your knowing.

    The details:

    Quote Originally Posted by Old Policy
    To ensure that your Wii Console is operating properly and efficiently, we may download updates, patches, upgrades and similar software to your Wii Console. In addition, we may disable unauthorized or illegal software that has been placed on your Wii Console without notifying you where necessary, in order to comply with applicable laws, assist law enforcement, protect us and our customers, and prevent the use and distribution of software obtained through improper channels."
    Quote Originally Posted by New Policy
    We may without notifying you, download updates, patches, upgrades and similar software to your Wii Console and may disable unauthorized or illegal software placed on your Wii Console to ensure that your Wii Console is operating properly and efficiently, comply with applicable laws, assist law enforcement, protect us and our customers, or prevent the use and distribution of software obtained through improper channels.
    The solution:
    Downgrade to the 3.2 firmware. Please follow this guide:
    http://www.wiihacks.com/faq-guides-t...atutorial.html

    3.4 Notes:
    Do I have to downgrade? The answer is "no". If you're comfortable with idea of Nintendo controlling your system, you do not have to downgrade. Your 1:1 copies will still work, for now.



    If you found this guide to be useful, please hit the in the corner. User feedback keeps me motivated!

    Helpful Threads:
    Dump & Burn discs | 3.3 / 3.4 Firmware FYI | Wii Disassemble | WiiClip Install

    Consoles:
    Wii - 4.1U - WiiKey 2 - USBLoader GX - SNES9X GX, Genesis Plus GX, FCE GX w. cover flow mods
    360 - Resident Evil S.E. - iXtreme LT 1.1 - JTag - FreeBoot 0.032 9199 Dash - NXE2GOD, XM360, XeXMenu 1.1, Flash360
    PSP - CFW 5.00m33, 16GB MSPD | DS Lite - DSTT w.1.17a r12, 8GB SDHC


  2. #2
    Senior Member admiral victorinox's Avatar
    Join Date
    Apr 2008
    Location
    michigan
    Posts
    4,940
    Thanks
    1
    Thanked 2,603 Times in 873 Posts
    theres also decensored games =P

  3. #3
    Junior Member
    Join Date
    Aug 2008
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I updated my Wii to 3.3 as soon as I bought it, but I have a lot of "scrubbed" and "RegionFriid" games working.
    How´s it possible?

  4. #4
    Junior Member
    Join Date
    Dec 2008
    Posts
    14
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by e3NiNe View Post
    [SIZE="4"]


    Firmware 3.4
    Released: November 17, 2008

    The problem:
    When Nintendo issues a firmware update, they prompt the user if they'd like to install it. A part of the 3.4 user agreement is longer being prompted permission. When a 3.5 is released, it will get installed without your knowing.
    Question:

    I have 3.4 already with D2pro D2E installed, so far all my burn games both NTSC and PAL are working. What if I disable the wireless network connection, since I don't really needed then Nintendo can't push the 3.5 to my console without my permission, correct?

  5. #5
    e39
    e39 is offline
    Member
    Join Date
    Dec 2008
    Posts
    1,029
    Thanks
    15
    Thanked 1,340 Times in 187 Posts
    Quote Originally Posted by skylab1 View Post
    Question:

    I have 3.4 already with D2pro D2E installed, so far all my burn games both NTSC and PAL are working. What if I disable the wireless network connection, since I don't really needed then Nintendo can't push the 3.5 to my console without my permission, correct?
    They can install it via disc too. Pop in a hypothetical Mario Galaxy 2 and it'll install whatever it wants.

    Brickblock it and the 3.3 update (part of the 3.4) won't run the disc unless you're IOS51 / Shop patched.

    Helpful Threads:
    Dump & Burn discs | 3.3 / 3.4 Firmware FYI | Wii Disassemble | WiiClip Install

    Consoles:
    Wii - 4.1U - WiiKey 2 - USBLoader GX - SNES9X GX, Genesis Plus GX, FCE GX w. cover flow mods
    360 - Resident Evil S.E. - iXtreme LT 1.1 - JTag - FreeBoot 0.032 9199 Dash - NXE2GOD, XM360, XeXMenu 1.1, Flash360
    PSP - CFW 5.00m33, 16GB MSPD | DS Lite - DSTT w.1.17a r12, 8GB SDHC

  6. 2 Users Say Thank You to e39 For This Useful Post


  7. #6
    Junior Member coolboy20062's Avatar
    Join Date
    Mar 2008
    Posts
    109
    Thanks
    19
    Thanked 8 Times in 7 Posts
    So your saying that the only bad thing about having v 3.3 is that you have to "scrub" every game you burn? It wont auto update to 3.4+, only 3.4 auto updates right?

  8. #7
    Junior Member
    Join Date
    Feb 2009
    Posts
    86
    Thanks
    3
    Thanked 21 Times in 12 Posts
    Quote Originally Posted by coolboy20062 View Post
    So your saying that the only bad thing about having v 3.3 is that you have to "scrub" every game you burn? It wont auto update to 3.4+, only 3.4 auto updates right?
    Ok this is my first post as I am pretty new to the wii scene and I think by saying "scrub" you mean to put the dummy data back onto any iso not being exactly 4,699,979,776 bytes in size? If my perception of scrubbing is correct and scrubbing removes all the dummy data?

    From all my reading by installing firmware 3.4 you have accepted the terms and conditions stating nintendo can update your wii at any point without letting you know. Before 3.4 ie 3.3 or 3.2 etc they could not do this.

    Im not fully familar with the Trucha signing etc but basically any disc that has been customed signed is disabled in 3.3 if my understanding are correct and Gecko OS is required to load Trucha signed discs on 3.3.
    Last edited by smity_oz; 02-09-2009 at 02:48 AM. Reason: *

  9. #8
    Junior Member
    Join Date
    Mar 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Greetings,

    First, I want to say thanks for all the precious info you provide to all of us.

    I am sorry if my question is already repeated and answered, I would like to ask one simple thing only,
    I have the 3.4 firmwire version unfortunatelly, could I downgrade to 3.2 and enjoy original and backup games, homebrew channels etc. without a change of damaging my console? Is it safe 100%?

    p.s what the things you can do with the homebrew channel?

    Thanks in advance!
    Last edited by Vylker; 03-04-2009 at 12:28 AM.

  10. #9
    Wiihack's Staff
    ~ ********* ~
    *UNDERSTAFFED*ONLY MK Contestants & ***** Supporters can PM MODS
    if u pm me for help...
    you better be a ***** donator

    Rossy's Avatar
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    846
    Thanks
    12
    Thanked 217 Times in 155 Posts
    Have you used the search function ? used the Tutorial section ?

    Did you know you can donate to help the running of this forum ?

    http://www.wiihacks.com/home.php

    hi...sorry we're busy, so only giving priority to supporting members like MK contestants / forum donators at this time...


    The advice given is up to you whether to act on it or not. NO responsibility is taken for you screwing up !
    Thanks for your understanding

  11. #10
    Junior Member Roy235's Avatar
    Join Date
    Mar 2009
    Location
    Brussels
    Posts
    30
    Thanks
    3
    Thanked 1 Time in 1 Post
    how can i find out which version my wii is?
    also, i have the homebrew channel so i don't wish to update my wii cuz i wanna keep playing fake games...but i saw that if i don't update i cannot connect to the internet...

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •