i found mario cart has upgrade 3.1j v3

if i install it , should it support all lower versions ? 3.1j v1 for example