Results 1 to 5 of 5

Thread: Genesis Plus GX Controller Issue

  1. #1
    Junior Member
    Join Date
    Jan 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Genesis Plus GX Controller Issue

    My classic controller is not working properly in the genesis emulator. It works with fce and snes9x. The problem isn't with the buttons, as they work fine, but the directional pad and analog stick aren't read at all. What is really confusing to me is that it works in the menu but not in the game. Hoping someone has a fix and it's much appreciated. I did try reinstalling the program through the browser but that didn't work. I'm fairly new to all of this so hopefully it is something simple.

    Thanks in advance.

  2. #2
    New Member emrextreme's Avatar
    Join Date
    May 2011
    Location
    Turkey
    Posts
    61
    Thanks
    24
    Thanked 7 Times in 6 Posts
    Confirmed. I've the same issue. Classic controller doesn't seem to work properly.

  3. #3
    Member
    Retired WiiHacks Staff
    Darkcide666's Avatar
    Join Date
    Jan 2010
    Location
    Upstate NY
    Posts
    3,719
    Thanks
    560
    Thanked 924 Times in 666 Posts
    Let me guess...It's a 3rd party or some $4 Chinese knock off? There are a lot of problems with non-official controllers and the Wii emulators. I can confirm that the official Nintendo brand classic controller works with all emulators that support it.
    "Hackers solve problems and build things, and they believe in freedom and voluntary mutual help." - Eric S. Raymond

  4. #4
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Pob3008's Avatar
    Join Date
    Nov 2009
    Location
    Liverpool
    Posts
    6,834
    Thanks
    918
    Thanked 2,108 Times in 1,487 Posts
    Blog Entries
    13
    +1 mine works fine.

  5. #5
    New Member
    Join Date
    Apr 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have an original Sega Gensis controller (G-Tron 4in1 port) and it's really weird. On one controller, 3 buttons on the directional pad work - the fourth does not. On the second controller, the directional pad doesn't work at all, but the 3 face buttons work.

    Both controllers have been tested with a Sega Genesis and work perfectly.

    But here's the kicker, using the same port, my SNES controllers work perfectly with the Genesis emulator. WTF? lol

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •