Results 1 to 8 of 8

Thread: Backups loading slow?

  1. #1
    New Member
    Join Date
    Nov 2009
    Posts
    33
    Thanks
    3
    Thanked 4 Times in 4 Posts

    Backups loading slow?

    I connected a USB hard drive to my softmodded Wii yesterday and noticed some issues with playing backups off of the HD. For instance, it took a full minute to get to the start screen for Mario Kart Wii. When I finally got into the game, the animations in the background of the menus were stuttering or completely stopped. To actually start a race took about 45 seconds. I'm using a 3.5" Azio USB to IDE enclosure (which is reported as working on the wiki list of supported devices) with a Seagate Barracuda 7200.7 200GB drive. I tried both WiiFlow 1.1 and USB Loader GX with the same general result

    I also had problems trying to FTP to the drive (using FTPii). Sometimes it would work fine, but sometimes it would cut out in the middle of an upload with a "No Such Device" error.

    Ripping games to my drive took anywhere from 3 to 15 minutes, is that normal?

    Backups on DVDs are still working fine as is all my other homebrew. Also, I tried loading a backup from a small 1GB USB stick and that worked fine also, so I'm suspecting it's the drive.

    I've read differing accounts of how Seagate drives work with a Wii, but most of the negative reports say that they don't work at all, not that they work but are slow. Has anyone ever had a problem with their hard drive (Seagate or otherwise), where it technically "worked", but it was just ultra slow?

    I have another drive (a Western Digital 80GB) that I'm going to try tonight. And one more question...I've already ripped about 20 games to the Seagate drive, is there any way to image that and apply it to the new drive without having to re-rip?

    Thanks in advance.

  2. #2
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    Was going to suggest you might be chugging along at USB 1.1 speeds there for a while, when you mentioned Seagate I'm not so sure.

    In WBFS manager there's a clone option or if that doesn't work then you can extract the isos from the WBFS and re-introduce them to your new WBFS volume.

    Western Digital ftw.
    Not really doing much Wii stuff these days.

  3. #3
    New Member
    Join Date
    Nov 2009
    Posts
    33
    Thanks
    3
    Thanked 4 Times in 4 Posts
    Thanks for the clone/extract iso advice. As for the possibility that my drive is running at USB 1.1 speeds.... When I connect it to my PC, it shows up as a USB 2 device, is there a way to determine how the wii is seeing it? And if so, is there a way to change it?

  4. 1 User Says Thank You jm21 For This Useful Post


  5. #4
    New Member
    Join Date
    Nov 2009
    Posts
    33
    Thanks
    3
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by Tealc View Post
    Western Digital ftw.
    Yep! Dropped my WD in the enclosure, made two partitions, formatted first to WBFS, attached to Wii, ripped Mario Kart Wii, played...loads lightning fast and no stuttering.

    A couple more questions though...I'm noticing that it takes a long time to copy games over from my PC using WBFS manager. A 3GB iso is taking about 45 minutes. Seems that it would be faster to burn to a DVD and then rip using WiiFlow/USB Loader on my Wii. Only problem is having to use a DVD-R for each one. From what I've read, DVD-RW's aren't supported for playing backups, but can they be read for ripping on the Wii? I'm guess no as it's probably a low level hardware thing, but it doesn't hurt to ask.

  6. #5
    Senior Member
    DA KINE WiiHacker
    mauifrog's Avatar
    Join Date
    May 2009
    Posts
    9,191
    Thanks
    307
    Thanked 9,584 Times in 2,974 Posts
    Blog Entries
    15
    Switch port on the pc, sound like you are on usb1. You need usb2 or it is super slow. Also make sure the drive stays cool when doing large transfers. If it gets hot, it will slow down. Should not be an issue with 1 game, but if you are moving lots of files keep it cool. I have a small 10 dollor fan I use I am moving a large volumes.
    Last edited by mauifrog; 11-18-2009 at 08:15 PM.
    Ipsa scientia potestas est.


    Warning: Piracy is NOT supported. Word your questions carefully.

  7. #6
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    3000MB at appx. 1MB per second takes 45 minutes (2700 seconds) = USB 1.1 (11Mbit/sec)

    Maybe your PC doesn't have USB 2.0? (400Mbit/sec)
    Not really doing much Wii stuff these days.

  8. 1 User Says Thank You Tealc For This Useful Post


  9. #7
    New Member
    Join Date
    Nov 2009
    Posts
    33
    Thanks
    3
    Thanked 4 Times in 4 Posts
    I think I may have figured out the problem. It might have to do with that original Seagate drive. I took a larger Western Digital drive out of my computer to use for my backups. Before I did, I copied everything on it (including some isos) over to the Seagate drive in the enclosure. I then swapped the two drives and put the Seagate in the PC and the WD in the enclosure. So now when I'm copying from PC to USB using WBFS, the source drive is the Seagate. I think it's reading slow, just like when it was attached to the Wii and trying to read the game being played. I became suspicious of this when unRARing a 4gb fileNwhere that drive was the source and destination. The day before (on the WD drive), it was taking about 10 minutes from start to finish. After I swapped drives, it took nearly an hour! Tonight I'm going to try putting the Isos on my main drive and add to my USB drive from there.
    Last edited by jm21; 11-19-2009 at 07:03 AM.

  10. #8
    New Member PivotGuy's Avatar
    Join Date
    Nov 2012
    Location
    California, US
    Posts
    3
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Interesting. So how does this apply to USB flash drives, if I were to use one?
    PC: HP Pavilion G7 Notebook
    OS: Windows 7 x64
    RAM: 4 GB
    CPU: Intel Core i3-2330M @ 2.2 GHz
    Disk Space: 446 GB Max

    Wii:
    Black, Softmodded (Mauifrog Style) on 4.3U

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •