Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Can't install Wads ERROR! (ret= -1)

  1. #1
    Junior Member
    Join Date
    Feb 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Can't install Wads ERROR! (ret= -1)

    I've installed many wads (mainly wiiware and VC games) without a problem but now suddenly i get this error and i dont know what's causing it. I tried to install Lost Winds and it started installing all the content stuff and everything but then near what would have been the end of the installation it says ERROR! (ret= -1), I've searched and havent seen any complaints of ret= -1 so i don't know what the problem is. Any help?

    Its not the specific wad thats the problem because i installed the exact same one at my friends without a problem.

  2. #2
    Junior Member
    Join Date
    Feb 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    please reply someone. if you dont know what to do then tell me please so i know i havent just asked a noob question that nobodys bothering to answer. thanks

  3. #3
    Wiihack's Staff
    ~ ********* ~
    *UNDERSTAFFED*ONLY MK Contestants & ***** Supporters can PM MODS
    if u pm me for help...
    you better be a ***** donator

    Rossy's Avatar
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    846
    Thanks
    12
    Thanked 217 Times in 155 Posts
    Start with the basics...
    Re download the WAD and try again
    Have you used the search function ? used the Tutorial section ?

    Did you know you can donate to help the running of this forum ?

    http://www.wiihacks.com/home.php

    hi...sorry we're busy, so only giving priority to supporting members like MK contestants / forum donators at this time...


    The advice given is up to you whether to act on it or not. NO responsibility is taken for you screwing up !
    Thanks for your understanding

  4. #4
    Junior Member
    Join Date
    Feb 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    but i know the wad is fine, plus i've now tried it with other wads and get the same problem... i dont really know what to do

  5. #5
    Wiihack's Staff
    ~ ********* ~
    *UNDERSTAFFED*ONLY MK Contestants & ***** Supporters can PM MODS
    if u pm me for help...
    you better be a ***** donator

    Rossy's Avatar
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    846
    Thanks
    12
    Thanked 217 Times in 155 Posts
    I belive that the ERROR! (ret= -1), actually means it is accessing an EMPTY folder OR the information could not be read........ Try swapping your SD card

    Just because the WAD "has" worked before it may have become corrupted - I've had the same problem myself , give it a try.......... what have you got to lose ???
    Have you used the search function ? used the Tutorial section ?

    Did you know you can donate to help the running of this forum ?

    http://www.wiihacks.com/home.php

    hi...sorry we're busy, so only giving priority to supporting members like MK contestants / forum donators at this time...


    The advice given is up to you whether to act on it or not. NO responsibility is taken for you screwing up !
    Thanks for your understanding

  6. #6
    Junior Member
    Join Date
    Feb 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have the answer!

    It continued to have the very same problem and it made me very angry.

    I thought i was just a patch or something so i downgraded my system and thought that would fix it but it didn't. Ath the starts of the downgrade i needed a program i could use to extract the files. That program happened to be winRAR. After i finished the wads still didnt install. So this is what i did.

    I'm going to guess that if it doesnt work for you then you either have
    A) a bad wad
    B) an incorrect region wad
    or the most common one
    C) your wad is in the WRONG format.
    more than likely when you down load a wad, it usually isnt in .wad format. But you rename it like title.wad, so the file thinks its a .wad, but it isnt. So what you need to do is download winRAR. When you open it, click the add button then go to files and click the append to add the file. Then when the file is added go to extract. Select the place to extract to and then do so. When its done go to where you extracted it to and then right click it and click extract to...(what ever the wad is) When done you should see a regular folder with that wad name. Open it. Add that wad into the wad folder on your sd card. Start it up and then install it.

    Thats what i did and i havent had any problems installing any of the wads. I installed like 5 or 6 when i figured it out i was so happy.

    Hope this helps

  7. #7
    Junior Member
    Join Date
    Dec 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'm having the same problem does anyone have a real solution besides switching media cards??? Everything works except for installing VC wads. I can install other wads and other things. My backuplauncher gamma 0.3 works and i can do anything on my wii using the homebrew channel except when I try to install Donkey Kong Country using WAD Manager 1.3 it won't install and i've downloaded 2 of the same wad from different sites and they are both NTSC which i'm in the US. It still doesn't work! I get ERROR! (ret = -1).

  8. #8
    Wiihack's Staff
    ~ ********* ~
    *UNDERSTAFFED*ONLY MK Contestants & ***** Supporters can PM MODS
    if u pm me for help...
    you better be a ***** donator

    Rossy's Avatar
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    846
    Thanks
    12
    Thanked 217 Times in 155 Posts
    Check the file extension of what you are trying to put on the SD Card

    Unzip or Unrar the file you have downloaded, the file should have the extension .wad anything else, and it will not be recognised by Wad Manager.
    Put the .wad file on to your SD card in to the WAD Folder.

    Start Wad Manager.

    In Wad Manager you will see a list of all the wad files you have in the folder named 'wad' on your SD card.
    Use up and down on the D-pad on the Wii Remote to select a wad file that you want to install.

    Once you have the wad you want to install higlighted press the + button on the Wii Remote
    to install that wad file onto the Wii, it will ask you if you are sure you want to install the wad,
    press the A button on the Wii remote to confirm you want to install the wad, or press B to cancel.
    Continue this process for all the wads you want to install.

    Once you have installed all the wads that you want, press the HOME button on the Wii remote (thats the button with the blue house on it), this will take you back to the Wii Menu.

    When you return to the Wii Menu you will find your brand new FREE Virtual
    Console games sitting proudly in your Wii Menu. Congratz.


    WARNING!!! DO NOT INSTALL MORE VC GAMES THAN YOUR WII HAS SPACE FOR!


    Uninstalling Virtual Console games

    To remove VC games from your Wii you must use the WAD Manager program, its not
    enough to simply remove them from the Wii via the Wii data management as removing
    them this way leaves behind a ticket.


    To uninstall VC games, simply start the Wad Manager just like you did to install the wads.
    Uninstalling the games is the same as installing them, just press the - button on the Wii remote instead of the + button when selecting the games you want to uninstall from the list.
    Have you used the search function ? used the Tutorial section ?

    Did you know you can donate to help the running of this forum ?

    http://www.wiihacks.com/home.php

    hi...sorry we're busy, so only giving priority to supporting members like MK contestants / forum donators at this time...


    The advice given is up to you whether to act on it or not. NO responsibility is taken for you screwing up !
    Thanks for your understanding

  9. 1 User Says Thank You Rossy For This Useful Post


  10. #9
    Junior Member
    Join Date
    Dec 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I've done that i'm doing it right but i was wondering what that error means and how i can fix it.

  11. #10
    Wiihack's Staff
    ~ ********* ~
    *UNDERSTAFFED*ONLY MK Contestants & ***** Supporters can PM MODS
    if u pm me for help...
    you better be a ***** donator

    Rossy's Avatar
    Join Date
    Dec 2008
    Location
    Australia
    Posts
    846
    Thanks
    12
    Thanked 217 Times in 155 Posts
    Error ret = -1 is to put it simply a missing file or an inability to read the file

    ret=-1 WAD file

    error describing a 404… file was not found...

    1) Your SD card is not formatted as FAT16 or FAT32 properly, reformat it.

    2) Appears, when there is no “WAD” folder on your device. (SD-card)

    ret=-1 DvD backup

    Specific cIOS Missing Install the required cIOS! For your HomeBrew App!
    Have you used the search function ? used the Tutorial section ?

    Did you know you can donate to help the running of this forum ?

    http://www.wiihacks.com/home.php

    hi...sorry we're busy, so only giving priority to supporting members like MK contestants / forum donators at this time...


    The advice given is up to you whether to act on it or not. NO responsibility is taken for you screwing up !
    Thanks for your understanding

  12. 1 User Says Thank You Rossy For This Useful Post


Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •