Results 1 to 8 of 8

Thread: Wii won't turn on

  1. #1
    New Member
    Join Date
    Dec 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wii won't turn on

    (not sure if this should go in the bricked section or not, move if needed)

    So my sister was playing on the Wii then my brother walked in and turned off the Wii from the mains, whilst they were playing. Later, she wanted to play but it wouldn't turn on. The light on the front of the Wii won't even turn on. I've tried turning the mains on and off again, nothings that I an do is working. My Wii has been softmodded and the game was being run from the disc. Any ideas? Please help quick.

    Thanks

  2. #2
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Pob3008's Avatar
    Join Date
    Nov 2009
    Location
    Liverpool
    Posts
    6,835
    Thanks
    923
    Thanked 2,108 Times in 1,487 Posts
    Blog Entries
    13
    Sounds like a hardware failure to me probably with the mains port

  3. #3
    New Member
    Join Date
    Dec 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Nope, it's on one of those long things that have several sockets. I've tried changing them round, taking all but the Wii off etc.

    Brother suggests it could be the fuse.

  4. #4
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Pob3008's Avatar
    Join Date
    Nov 2009
    Location
    Liverpool
    Posts
    6,835
    Thanks
    923
    Thanked 2,108 Times in 1,487 Posts
    Blog Entries
    13
    I was suggesting it damaged the port on the wii where the plug connects to the wii

  5. #5
    New Member
    Join Date
    Dec 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So would that be beyond repair?

  6. #6
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Senior Moderator
    Pob3008's Avatar
    Join Date
    Nov 2009
    Location
    Liverpool
    Posts
    6,835
    Thanks
    923
    Thanked 2,108 Times in 1,487 Posts
    Blog Entries
    13
    Not really, but u will need to rule out the cable first before anything

  7. #7
    WiiHacks Staff
    Only Site Donators Can PM Staff
    Forum Administrator
    IRC AOP
    skellinator's Avatar
    Join Date
    Aug 2010
    Location
    SE United States
    Posts
    6,067
    Thanks
    833
    Thanked 2,083 Times in 1,757 Posts
    I have seen this happen with a friends wii. Unplug the power cord from the wii and the wall. Let it sit for about 20 mins then try again. There is a capacitor in that block that causes this to happen. Hopefully that's all that's wrong with yours.

  8. #8
    New Member
    Join Date
    Dec 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    @skellinator: Just found this on the Nintendo site. Said 2 minutes but either way, it works!!

    You can lock thread or whatever now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •