Results 1 to 9 of 9

Thread: Black Classic Controller only works sometimes

  1. #1
    New Member
    Join Date
    Oct 2012
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Black Classic Controller only works sometimes

    I am having an issue where my classic controller only works maybe 10% of the time at random with any of my emulators other than Genesis Plus, it works all the time. It also works in the hbc menu always and in other homebrew apps. It is the black controller with the clear buttons and nintendo logo pressed into the back so I am pretty sure its official. I have searched and seen where people plug and unplug it at certain times and things like that, is there a more permanent fix so it will always work?

  2. #2
    Member
    Join Date
    Jan 2009
    Posts
    2,692
    Thanks
    254
    Thanked 396 Times in 369 Posts
    Color has nothing to do with the problem.
    Buy a quality one.

  3. #3
    New Member
    Join Date
    Oct 2012
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    What do you mean by quality one? Is the one I bought low quality? Should I have gotten the white one instead? As a side note I tried it with the snes emulator earlier and it seems to be working fine with it, the problem is most prevalent in mame.

  4. #4
    Member
    Join Date
    Jan 2009
    Posts
    2,692
    Thanks
    254
    Thanked 396 Times in 369 Posts
    You may have the right finding that I'm not familiar.

  5. #5
    New Member
    Join Date
    Oct 2012
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Im sorry that sentence doesnt really make sense to me.

  6. #6
    New Member
    Join Date
    Jul 2010
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts
    You need to setup Mame to use the black controller, reassign keys.

    Though I think there are 2 versions of MAME or SDLMAME and one of them i don't think works with my black controller.
    Last edited by nyder; 10-30-2012 at 01:40 AM.

  7. #7
    New Member
    Join Date
    Oct 2012
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am using SDLMAME and it worked no problem once without adjusting any settings, I havent seen any controller settings that would define the type of controller I use, but when it did work it allowed me to assign the buttons. Now when I try to assign buttons I get not response from them classic controller. I just downloaded mame wii and I will give it a shot and post my results. thanks!

  8. #8
    New Member
    Join Date
    Oct 2012
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    As far as I can tell all the versions Ive come across, sdlmame and mamewii, are both sdlmame. Now I am also having an issue where when I put new roms in the mame/roms directory they dont show up, only the original four I loaded. That makes no sense to me, any thoughts?

  9. #9
    New Member
    Join Date
    Jul 2010
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by thebrandoninator View Post
    As far as I can tell all the versions Ive come across, sdlmame and mamewii, are both sdlmame. Now I am also having an issue where when I put new roms in the mame/roms directory they dont show up, only the original four I loaded. That makes no sense to me, any thoughts?
    I put roms in MAME/ROMS on both my usb & sd card. I think before they were only reading them off the SD card, might of changed, not sure.

    They don't take up much space anyways, so it's not a big deal to me to have them in both.

    I checked the version i have an apparently i have .5 and .6

    I have problems with .5, but .6 works nice, but i left a a few things on the wiimote, like the coins, starting game, getting the mame menu because i think maybe it didn't recognize the - and + keys on the black classic controller. You can change the main controls for everything, then touch up each game.

    Mame is one of my most used programs on the wii. Nothing like classic arcade games and they scale up on my 1080p TV nicely, unlike most the Wii games.

    Sorry I'm not more specific, it's been awhile since i put it on there, and once i got it working, i left it alone. =)
    Last edited by nyder; 11-01-2012 at 04:11 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •