Results 1 to 2 of 2

Thread: Beatles Rock Band - Game runs but I'm stuck at "Loading" screen

  1. #1
    Junior Member
    Join Date
    Jan 2009
    Posts
    25
    Thanks
    1
    Thanked 2 Times in 2 Posts

    Beatles Rock Band - Game runs but I'm stuck at "Loading" screen

    I'm using GX. Every other game I have works fine. I have no problems with any of the other 'instrument games' via usb loader.

    The actual Beatles game loads up just fine for me (no green/black/error screens). I can get into the game and select my songs, difficulty, etc. When I try to start the songs, it goes to the loading screen and just stays there. It won't go into the actual play screen.

    The game never actually freezes, it just keeps trying to load. I even hear the old school announcer clips it normally plays with the cheering background while it tries to load. And the screen does the slow zoom in and out thing. When i press the home button, i get the "no home" icon.

    Anyone else had this problem? Know of any fixes for it?


    By the way, I can run the game just fine via backup disc though the disc channel, I just want it to be playable via my hard drive.

    any help or tips is appreciated.

  2. #2
    Junior Member
    Join Date
    Aug 2009
    Posts
    2
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Are you running PAL or NTSC? I can't even get it to run and I have the NTSC version, supposedly. All I get is a flash of green and then a black screen.

    I am also using GX and every other game runs perfectly fine. RB2, Band Hero, Lego Rock Band and just about every other GH release run without any problems. Only GH Aerosmith doesn't work with my instruments, which I am trying to solve, too.

    Bottom, line, how did you get your to run under GX? I'm on 4.2 and have followed all of the instructions on this forum.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •