Results 1 to 4 of 4

Thread: New DSi XL Help

  1. #1
    New Member
    Join Date
    Apr 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    New DSi XL Help

    Hey guys. I just purchased my son a new DSi XL to give to him at Christmas. I opened it and saw that the version is 1.4.1. From what I have read the versions are now way past this. I was wondering if anyone could direct me to a good page about what card I should buy, etc. to get me started. Everything I have found is for version 1.4.1 but I would like to update to the latest possible so I need to know what card to get, etc. Thanks for any and all help.

  2. #2
    Senior Member
    WiiHacks Staff
    Nancy the Moderator

    VWA, Game Master, News Hound
    Only site donators may send a PM to WiiHacks Staff
    Red_Gh0st's Avatar
    Join Date
    Jul 2009
    Location
    Puerto Rico. Sexyness: 2376
    Posts
    6,289
    Thanks
    628
    Thanked 2,142 Times in 1,350 Posts
    Blog Entries
    26
    Update to 1.4.3 and get a Supercard DSTWO, Acekard2i, iSmart MM, etc. Don't get R4 clones.

  3. #3
    New Member
    Join Date
    Apr 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Excellent! Amazon has the Acekard21 and a 16g SD for 40 bucks. I have never even touched a DSi until I turned this one on and got the version. I am a programmer and pretty much everything we have is done including a PSP, Droid Bionic, Xbox 360 and a Wii but I am popping my cherry on his new DSi. Is there a certain way to update it or should I just hook it up to WiFi and let it go? I am not sure what the latest version is or if they even give you options of what upgrade to go to.

  4. #4
    Senior Member
    WiiHacks Staff
    Nancy the Moderator

    VWA, Game Master, News Hound
    Only site donators may send a PM to WiiHacks Staff
    Red_Gh0st's Avatar
    Join Date
    Jul 2009
    Location
    Puerto Rico. Sexyness: 2376
    Posts
    6,289
    Thanks
    628
    Thanked 2,142 Times in 1,350 Posts
    Blog Entries
    26
    Simply try going to the SHop Channel it will prompt for the update. You have to go to settings and accept the EULA agreement and all that.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •