Results 1 to 3 of 3

Thread: DS Lite Screen Probs after Shell Change

  1. #1
    New Member
    Join Date
    Dec 2009
    Posts
    15
    Thanks
    3
    Thanked 0 Times in 0 Posts

    DS Lite Screen Probs after Shell Change

    Hi guys (and girls )
    I've posted this on the DS sister-site, but no replies as yet!
    May as well try all options!

    I changed the Shell on a broken DS Lite yesterday, as well as the top screen.
    The screen works, as I've tested it on a spare MB (which unfortunately lacks P6 dock)
    Once I'd changed the top screen, and replaced top case section, I tested it out (using original MB), and it worked fine.
    I then reassembled everything (apart from the last piece ie backing of the lower case) tested by holding battery on contacts - fine.
    Fixed the rest of the case together, secured all screws, turned power on -- damn!
    The battery/power light stays on (green) but both screens are black.

    I took the casing off again, linked up battery - nothing.

    At this point I checked all screen connections etc, all fine.
    Removed MB and replaced with "test" MB -- lights up, works fine (obviously no touch screen, with broken P6)
    So the ribbon cables aren't damaged.
    Put original MB back in, tested, nothing (power light stays on, but still a black screens)

    I've reassembled it all now, and have left it on charge (somehow hoping this might help! )

    Anyone got any ideas on this ie potential causes/fixes?

    Thanks!!

  2. #2
    New Member erikie's Avatar
    Join Date
    Oct 2009
    Location
    Netherlands
    Posts
    524
    Thanks
    8
    Thanked 170 Times in 141 Posts
    Blog Entries
    2
    did you have a close look at the power light? It stays on and does not slight vary in color?
    It probably hangs on loading the bootrom from the wifi module. Check that one. Otherwise I would say the mobo is toast.
    Something might have broken inside it. Have many of those lying aroung. There good for spare parts only.
    Also P6 connectors are replaceble you know. It is not an easy job but did it many times
    If you think I helped you please click the little thanks button
    Send me a PM if you have any questions regarding unbricking with infectus mod chip or post a message in here http://www.wiihacks.com/bricked-wii-...installed.html

  3. #3
    Member
    ~Former Wiihacks Staff~
    *~ IRC HOP ~*
    thucncao's Avatar
    Join Date
    Jan 2009
    Location
    USA
    Posts
    1,054
    Thanks
    54
    Thanked 191 Times in 136 Posts
    If you try to turn on the DS and the screen flickers and then shut off within a second or so check to make that your screen cables are in there tightly. It happened to me when i first changed the shell. If the problem still persist then you might have to get a new screen.
    Come to the Irc room to get help or just have fun

    Motivation alone is not enough. If you have an idiot and you motivate him, now you have a motivated idiot.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •