Results 1 to 1 of 1

Thread: CycloDS firmware 1.56 Beta 4

  1. #1
    Senior Member
    Join Date
    Mar 2009
    Location
    USA
    Posts
    5,552
    Thanks
    364
    Thanked 2,240 Times in 1,111 Posts
    Blog Entries
    8

    Arrow CycloDS firmware 1.56 Beta 4

    Team Cyclops has released CycloDS 1.56 Beta 4 firmware for download.



    Source - CycloDS Revolution
    Download - HERE

    To install the update, unzip the downloaded file and place the update file on the root of the microSD card, then boot up as normal and the update will install automatically.
    ----------------------------------------------------------------------------------------


    Release date: 2nd December, 2009

    CycloDS Evolution v1.56 BETA 4 firmware has been released for testing. Changes include:

    * Many internal changes
    * Tweaked automatic game protection patcher, should fix delays with some games
    * Game compatibility fix (4262, 4323)

    We'd like to apologise for the lack of activity from Team Cyclops recently. We've had our full attention focused on some interesting new developments - but that's all we can say for now This BETA release has minor changes in terms of functionality/compatibility but a lot has changed under the hood so we're eager to hear back from those who will test this to ensure that its on par with previous releases.

    Regarding recent Ubisoft releases - these games incorporate a whole new form of protection and we are currently working on a generic fix. In the meantime, please use the pre-patched releases which are available (assuming of course that you own an original copy of the corresponding game!).
    Change log
    ----------

    - v1.56 BETA 4:

    * Many internal changes
    * Tweaked automatic game protection patcher, should fix delays with some games
    * Game compatibility fix (4262, 4323)

    - v1.56 BETA 3:

    * Fixed bug affecting 3541
    * Game compatibility fix (4177)

    - v1.56 BETA 2:

    * Fixed regression relating to the update of the automatic game protection
    patcher

    v1.56 BETA 1:

    * Updated the automatic game protection patcher to support recent releases
    such as 4159, 4160, 4162


    Here is a CycloDS compatibility list - http://cyclods.ject.pro/
    Last edited by Stomp_442; 12-13-2009 at 07:12 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •