Just as the title says, a few hours ago, acekard official site has released the update patch for 3DS V4.2.0-9, this is a good news for ak2i users, they have been waiting for about two weeks, and finally they can update.

download :

Acekard 2i update patch for 3DS V4.2.0-9

Latest acekard 2i firnware AKAIO V1.89

So now nearly all the popular cards are all working on the 3DS V4.2.0-9, including acekard 2i, r4i gold 3ds (r4ids.cn) and DStwo, those are top 3 card i always recommend, if you want to buy any of them, just make sure you can buy a preflashed one which means you dont need to update it with a DS Lite by yourself when you receive it. Just like the news quote from here: buy Acekard 2i flashcart for DS DSi 3DS-dsflashcart.com

"Good news: Acekard 2i has released the Ak2i update patch for 3DS V4.2.0-9, which means Acekard 2i is working great on 3DS V4.2.0-9 and DSi V1.44 now. So the acekard 2i we send out can work on the latest 3DS V4.2.0-9 and DSi V1.44, you dont need to update it with a DS Lite when you receive."

I will find a time later to make a video guide about update acekard 2i for 3DS V4.2.0-9. Stay focused on this forum, guys.