Results 1 to 2 of 2

Thread: DSi card replacement

  1. #1
    New Member
    Join Date
    May 2012
    Location
    Bairnsdale, Victoria, Australia
    Posts
    2
    Thanks
    1
    Thanked 1 Time in 1 Post

    DSi card replacement

    hi my brother has a DSi with an iEdge card but updated his DSi to 1.4.3a and now it doesn't work and as far as i can find theres no firmware update for this. (please point me in the right direction if im wrong)
    So he needs a new card so i was looking for some affordable priced options.

    P.S im located in aus if it makes a differnce

  2. #2
    New Member dsflashcart's Avatar
    Join Date
    May 2012
    Posts
    252
    Thanks
    7
    Thanked 61 Times in 51 Posts
    yeah, iedge card can not work on th e latest DSi or 3DS firmware, you need to buy a new card instead. There are always three cards we recommend, r4i gold 3ds, Acekard 2i. I would suggest you buy the Acekard 2i here: buy Acekard 2i flashcart for DS DSi 3DS-dsflashcart.com or r4i gold.. both o f them are working great on your DSi V1.43. Pirces of them are not very expensive either. Any other questions, just leave your reply.
    Do yourself a favor, don't buy crappy flashcarts.

  3. 1 User Says Thank You dsflashcart For This Useful Post


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •