Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Help! Can't play NTSC games on PAL 4.1e

  1. #1
    Junior Member
    Join Date
    Feb 2010
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Help! Can't play NTSC games on PAL 4.1e

    Hi All

    New to this game and this is my first post. So sorry if i am repeating something that is old but i did try to search the forums and found nothing to help me.

    Anyway, my problem is that I just installed a drivekey on my Wii and it is working fine with PAL original and backup games. But the main reason I modded it so i can play MLB Power Pros 2008, which i have bought original nearly over a year and a half ago from the States and never even opened it. So when i play the game it comes up in the channel and i have allowed updates, but i get a very serious update message saying something in the form of if i update i can comprimise the console, possibly meaning it will get bricked. So i did not update.

    Can someone help me reslve this or point me in the right direction, because i thought if i was on 4.2 then import games won't work.

    thanks in advance.

  2. #2
    Senior Member Krank's Avatar
    Join Date
    Jan 2010
    Posts
    8,895
    Thanks
    953
    Thanked 4,321 Times in 2,128 Posts
    Blog Entries
    7
    Set it to block disc updates.

  3. #3
    Junior Member
    Join Date
    Feb 2010
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts
    i tried that and it does not help, because when i do that and load the game i just get a black screen.

  4. #4
    New Member
    Join Date
    Dec 2009
    Posts
    11
    Thanks
    3
    Thanked 2 Times in 2 Posts
    Softmode it then install Priiloader and set Region Free.

  5. 1 User Says Thank You cotosilv For This Useful Post


  6. #5
    Junior Member
    Join Date
    Feb 2010
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Hi costosilv and thanks for the reply. Like i said i am new to this stuff so i am unsure how to go about it, is there any informative links or tutorials you can point me to to assit me in how to softmod it and get Priiloader. Also i was reading up on how to setup the Hombrew channel and add Gecko Os. Is that the same thing you are telling me? Will that work?

  7. #6
    New Member
    Join Date
    Dec 2009
    Posts
    11
    Thanks
    3
    Thanked 2 Times in 2 Posts
    Use this tutorial.
    First check the videos.
    Good luck.

  8. 1 User Says Thank You cotosilv For This Useful Post


  9. #7
    Junior Member
    Join Date
    Feb 2010
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts
    hey cotosilv, thanks for the info.

    Before i try that i put the NTSC game back in and allowed all updates through drivekey. Now when i boot the game i get the message below:

    "In order to use this software you must perform a wii system update. Select OK to begin update"

    This was a different message that the one before, i think because i connected my wii to the internet. but the question is do i update from a NTSC game or will that brick it. I have tried to put ina latest game for the update but i think i am up to date on the 4.1e firmware. would updating throught the wii menu help?

    any advice will be appreciated. thanks in advance.

  10. #8
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    It's unlikely that the NTSC disc from some 2 years ago would update your System Menu as it probably came with a really old update included. What it might have though is an IOS which you do not have installed.

    Usually it is not recommended to update using a foreign disc but in this case I don't think too many problemas will come from it, certainly if the year in the game title is anything to go by.

    You shouldn't need to run an update for a 2 year old game really as you should have everything you need, strange that you don't.

    Would I run the update? Probably, as I am bootmii/boot2 protected. Are you?
    Not really doing much Wii stuff these days.

  11. 1 User Says Thank You Tealc For This Useful Post


  12. #9
    Junior Member
    Join Date
    Feb 2010
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Hi tealc. thanks for your advice. no i am not bootmii/boot2 protected. like i said i am just learning all this and it is new to me. so just getting my head around all this stuff and all the options. So will probably back up my nand and then update it. but your logic is also wise, that a game from 2008 should not mess anything up, but maybe i should not risk it.

  13. #10
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    If you had an ISO of the game you could open it with Wiiscrubber and examine the contents of the update partition and compare it with your own signcheck/dop-ios report, but that's rather advanced stuff if you are just starting out.

    Not much in the way of sources available to download this ISO either, probably due to it's limited appeal and age.
    Last edited by Tealc; 02-28-2010 at 05:01 AM.
    Not really doing much Wii stuff these days.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •