Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Important DK Info regarding newer game titles

  1. #21
    Junior Member
    Join Date
    Mar 2009
    Posts
    6
    Thanks
    2
    Thanked 3 Times in 2 Posts

    Us I found a solution :)

    I finally got my Madworld backup to work.

    The game needs to do some kind of update in order to avoid the blackscreen of death. It doesn't really make sense though, because I'm on 4.0 which was released after the game disc. Anyway, all you need to do is disable the update block feature in the drivekey menu, set it to allow all updates. Insert the disc load it up and then turn the block update feature back on. The disc will now work with the block feature enabled.

    Important: I have only tried this with a backup from the same region as my wii. I do not know what will happen if you do a disc update to 4.0 with a backup from another region. I'm not brave enough to try it.

    Modderman, you may want to change edit to the original post, the blackscreen of death happened on my drivekey only modded wii. I have never had any softmods whatsoever, and this issue only happens to games that need to perform an update in order to play. So far they include:

    Deadly Creatures, Madworld, and Ready to Rumble: Revolution. If anyone knows of more titles, please post them. We need a list
    Last edited by techn0; 03-30-2009 at 09:08 AM.

  2. 2 Users Say Thank You to techn0 For This Useful Post


  3. #22
    Junior Member
    Join Date
    Mar 2009
    Posts
    11
    Thanks
    9
    Thanked 3 Times in 2 Posts

    madworld working for me after update to v4.0

    I was also having troubles with MadWorld and Animal Crossing City Folk (Is this a newer title too?). Both of these asked for a system update. When update blocking was turned on in DK config menu then they would just go straight to black screen of death. I did system update (to v4.0) from wii setup menu. After that, both games worked fine. I'm burning verbatim dvd-r at 8x speed using Mac disk utility on my imac. Got ntsc ISOs from TL. Great source of wii games for those that have membership.

  4. #23
    New Member
    Join Date
    Mar 2009
    Posts
    66
    Thanks
    8
    Thanked 20 Times in 11 Posts
    You only want to accept updates for your region, never do allow all updates.

  5. #24
    Junior Member
    Join Date
    Mar 2009
    Posts
    11
    Thanks
    9
    Thanked 3 Times in 2 Posts
    Yup. Good point from badz2211. I always have my DK set to either block 'all' updates or 'import' updates. I have an NTSC system and have had no trouble finding USA/NTSC versions of games so far and plan to avoid PAL altogether. Just safer that way.

  6. #25
    New Member
    Join Date
    Mar 2009
    Posts
    79
    Thanks
    4
    Thanked 13 Times in 9 Posts
    Thanks a lot for the info

  7. #26
    Junior Member
    Join Date
    Mar 2009
    Posts
    20
    Thanks
    5
    Thanked 6 Times in 4 Posts
    My NTSC Madworld wanted to update on my PAL DK wii 4.0 (either that or it gave me the black screen of death). I figured I'd just get the PAL version and update from there... turns out the PAL version works without trying to update while the NTSC version still wants to update...
    oh what misteries the universe holds

  8. 1 User Says Thank You siriusbs For This Useful Post


  9. #27
    Admin / Super Mod ModderMan's Avatar
    Join Date
    Nov 2006
    Location
    GVR
    Posts
    8,841
    Thanks
    758
    Thanked 1,418 Times in 328 Posts
    Blog Entries
    15
    thing is you needed to update the wii fw to play madworld..and in alot of other games..really simple..

    now if all updates are blocked....game cannot update your wii to be able to play that particular game....

    now its been covered many times before...that if you update your wii with an out of region game.....you have a 95% chance of semi-bricking you wii

    you should only update your wii with a new release game from the same region as your wii...

    Wiihacks Super Mod / Admin

  10. #28
    Junior Member
    Join Date
    Jan 2009
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by ModderMan View Post
    thing is you needed to update the wii fw to play madworld..and in alot of other games..really simple..

    now if all updates are blocked....game cannot update your wii to be able to play that particular game....

    now its been covered many times before...that if you update your wii with an out of region game.....you have a 95% chance of semi-bricking you wii

    you should only update your wii with a new release game from the same region as your wii...
    ModderMan is RIGHT he knows with he is talking about. I have a Wii (PAL) fitted with a wii-key which was put in 2 years ago and I have ONLY updated with game from my region and my Wii is still working fine. So he is right ( Please note that I still have not done the Wii-key update for my mod chip version 1.9s )

  11. #29
    Junior Member
    Join Date
    Apr 2009
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    great thread

    ok so i have DK in mine w/ no softmods....had the same issue w/blackscreen on madworld...i reset my DK to allow local updates(ntsc) and game plays great.....the only issue i have now is with Super mario Galaxy telling me it cannot read disk on an original game disk.....for some reason i think it might actually be a disk issue because i currentl can play all original and backup disks except this one.....any ideas?






    ok i just tried something i read on another post.....hit the home key when cut screen appears and no problem
    Last edited by bootlegerr; 04-21-2009 at 11:16 AM. Reason: new info

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •