Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: D2Pro9 Canadamods - Having Problems

  1. #1
    Junior Member
    Join Date
    Nov 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    D2Pro9 Canadamods - Having Problems

    Hello All,

    I had recently purchased a D2Pro9 Mod Chip along with the Wii Clip from Candamods. This was my first mod to a Wii but have done many previous gen systems yet always liked the solderless versions out there.

    Installed my chip as per instructions and put it back together and everything worked great.

    Problem came when I rave to a friend and my sister how much I liked it. They each ordered from CanadaMods, one the version for my sisters D2B cut pin Wii and my buddy got his for the D2E. Each of them ordered the correct mod chips and had me install them. Upon install I have the same result, solid red light on the chip and the drive does not want to work. Fiddled some more with it and the drive works but will not read backups.

    I tried to call CanadaMods but cannot get through. Does anyone know the best method to try to get help with them? I will send an e-mail right now and see what I hear back.

    Any thoughts you might have would be GREATLY appreciated. I can get pics if needed.

    Thanks!
    Last edited by MXZDrew; 12-29-2008 at 08:31 PM.

  2. #2
    New Member
    Join Date
    Dec 2008
    Posts
    53
    Thanks
    5
    Thanked 3 Times in 2 Posts
    I am sure that they are busy. They will get back to you soon i am sure.

    If your pins arent bent, are you sure that the clip is fully seated? I thought mine was and it turns out that i was not pressing hard enough and it was not seated evenly on every side. Once i did that all worked fine.

    If it is solid red then it is not installed correctly. You need to see red, then blue.

  3. #3
    Junior Member
    Join Date
    Oct 2008
    Posts
    14
    Thanks
    5
    Thanked 8 Times in 8 Posts
    I'm sure you got in touch with them already.. but I've always been successful messaging them on here... You probably are having the same issue i had.. but I was having an issue with the d2e.. d2b was no problem at all.. talk to Al if you haven't already.. he'll get you sorted..

  4. #4
    Junior Member
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Just to add in my 2 cents ... canadamods is HORRIBLE at customer service and support. It looks like you were ignored like I was.

  5. #5
    Junior Member
    Join Date
    Oct 2008
    Posts
    14
    Thanks
    5
    Thanked 8 Times in 8 Posts
    how did you try contacting them? As I said PM'ing on the forum is the best. Calling is not the best option..

  6. #6
    Junior Member
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    4
    Thanked 0 Times in 0 Posts
    I would get replies sometimes, but just stuff like "I'll send you the pics" or just chat back and forth. Nothing really helpful. And I PM'ed him, emailed him and tried to get his attention on this forum. I will try to PM again.

  7. #7
    Junior Member
    Join Date
    Nov 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hey Propho,

    Thanks for the tip... No, still not sorted out. STILL no response from them. I just left a message on Al's cell phone as listed on CanadaMods website and offered 48 hours to return my call or I am just issuing chargebacks through MasterCard. There service thus far SUCKS. I know many of you love them,and I did to hence ordering 2 more chips... after these two don't work I am not feeling the love anymore.

    I am a very easy going customer and know the nature of the modchip biz so I am trying to be patient but I won't be screwed.

    Thanks to all of you for chiming in on the subject as well.

  8. #8
    Wiihacks Recommended
    Pro Installer/Store
    Senior Member
    Spyman's Avatar
    Join Date
    Jun 2008
    Location
    Greater Toronto Area
    Posts
    1,546
    Thanks
    33
    Thanked 123 Times in 106 Posts
    Quote Originally Posted by LakersFan View Post
    I would get replies sometimes, but just stuff like "I'll send you the pics" or just chat back and forth. Nothing really helpful. And I PM'ed him, emailed him and tried to get his attention on this forum. I will try to PM again.
    You were likely asking during a very busy time, and if its a chip/clip problem (and the majority of those problems are end user) then its possibly why there was a delay on my part to help with that. Send me a PM with that information and I can try to help out but really the sure method is to replace the clips if you didnt do the install correct the first time.

    @MXZDrew
    PM me your email so I can have someone check it maybe you're just being filtered as spam, if its tech support you need then PM me for help.
    Send me a PM if you need any Canadamods.ca support

    $9.95 Flat Rate Shipping to Canada & USA
    Official Support for Canadamods. I am here to help.

    email: sales@canadamods.ca | website: http://www.canadamods.ca | Phone: +1 416 728 0648

    We are the Official Distributors for: P.3Key, Wode JukeBox, WasabiDX, WiiKey, DriveKey, M3i & More - Always Authentic Guarenteed !
    Buy Wode JukeBox v2.0 here: Here

  9. #9
    Junior Member
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Yep. For the record, as soon as I PM'ed Spyman after my post above, he replied and offered to get my RMA started. I since had fixed my eject issue on my own (not anything due to the fault of Canadamods), so everything is working well.

    I blame the problems I had not on Canadamods or Al, but on the crappyness of the Wii-Clip. However the frustration was taken out on CM because they were initially slow (to absent) to respond to my problems.

    Take it for what it's worth.

  10. #10
    New Member
    Join Date
    Dec 2008
    Posts
    53
    Thanks
    5
    Thanked 3 Times in 2 Posts
    Quote Originally Posted by limp360 View Post
    Canadamods (specifically AL) is a douche bag. Rip off. Ordered 10 d2pro solderless and received soldered d2pro . No respose toemails or phone calls(because they received money) no need to responde right *i*khead. Dont order from them rip u off
    Are the soldered as you said or do they need soldered? Maybe you bought clips which have the chips soldered on them. Your post is confusing.
    3.2u d2pro9 v3 w/clip
    Homebrew channel for NES and SNES games.
    NeoGamma R8 Beta 12
    cIOS Rev 4

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •