Results 1 to 2 of 2

Thread: D2pro and newer games

  1. #1
    New Member
    Join Date
    Dec 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    D2pro and newer games

    Hi I'm a total noob however I managed to upgrade the D2pro to 1.8 and the Wii is running on ver. 4.2. It seems most newer games are not working, can anyone help? thank you

  2. #2
    New Member
    Join Date
    Jan 2009
    Posts
    17
    Thanks
    5
    Thanked 1 Time in 1 Post
    I'm not an expert, but it sounds like either your games are out of region or they have been "scrubbed". Later wii firmwares will not play these without wii software modifications.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •