Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: D2Pro9 v2, D2C2, and System Menu 3.3u

  1. #1
    Junior Member
    Join Date
    Jul 2008
    Posts
    30
    Thanks
    0
    Thanked 2 Times in 2 Posts

    D2Pro9 v2, D2C2, and System Menu 3.3u

    Good day,

    Would just like to add another voice to those users continuing to experience problems with the D2Pro9's current and recent firmware revisions (1.6 utility disc, 1.5 utility disc, and whatever the prior one was).

    My system occasionally likes to do inching, occasionally likes to have DRE-type problems, and occasionally crashes WiiWare if there's a disc in.

    All of this only happens with system menu 3.3u, and does not happen with 3.2u

    Unfortunately, someone inadvertently upped me to 3.3u again and I've got to downgrade once again. No big deal, but it's got me wondering...

    ...Does anyone have a workable (other than doing any soldering -- I got a WiiClip for a reason--shaky hands) solution for a firmware combination on a D2C2 system with 3.3 system menu? What's working for you?

    ...patiently waiting for next firmware utility disc, otherwise!

    Appreciate any opinions.

  2. #2
    Member
    Retired Staff Member

    Join Date
    Jun 2008
    Posts
    1,494
    Thanks
    70
    Thanked 230 Times in 116 Posts
    I don't believe SPI Flash version (1.6, 1.5, etc) alone is the problem. The Actel H/W version is more important, so whatever H/W version that ships with D2Pro9v2 for D2C2 is what you want to get to. Members Spyman & GModz should be able to tell you exactly.

  3. #3
    Junior Member
    Join Date
    Aug 2008
    Location
    Italy - Europe
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have a D2C2 Wii Drive with D2PRO V3 (D2E compatible) installed and fully working on 3.3e, man

    Try upgrading firmware using programmer.

    Good luck!

  4. #4
    Junior Member
    Join Date
    Jul 2008
    Posts
    30
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Actually what I'm trying now is a combination of FW1.6 on the modchip and "Region Patcher Off" per more than one suggestion 'round the intarwebs. Will post again if experiencing further problems, so far it looks good. Time to torture-test :-p

  5. #5
    Junior Member
    Join Date
    Jul 2008
    Posts
    30
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Regrettably, not the solution.

    Not only that, but for some odd freaking reason I can't get any homebrew program to initialize network properly -- aside from Homebrew Channel -- in order to downgrade sys menu :-/

    most annoying. time to open 'er up and take a look at the chip's seating.

  6. #6
    Wiihacks Recommended
    Pro Installer/Store
    Senior Member
    Spyman's Avatar
    Join Date
    Jun 2008
    Location
    Greater Toronto Area
    Posts
    1,546
    Thanks
    33
    Thanked 123 Times in 106 Posts
    The d2pro9 v2 usually ships with 2.0 firmware and 1.3 spi firmware, some shipped with 2.1 firmware and 1.5 firmware. The older v3 also has similar firmware. The new v3 we are getting in a few days hopefully has 2.3 and 1.6 firmware with d2e support.
    The 2.3 actel firmware and 1.6 spi seems to fix most inching problems people get. You can get the 'inching' problem from an incorrectly installed wiiclip though, we've seen a couple of cases where this was the issue. Make sure none of the pins are bent, and straighten them up with a blade if it is. Once I get my camera back I have a few videos on it that I will upload for troubleshooting.
    Send me a PM if you need any Canadamods.ca support

    $9.95 Flat Rate Shipping to Canada & USA
    Official Support for Canadamods. I am here to help.

    email: sales@canadamods.ca | website: http://www.canadamods.ca | Phone: +1 416 728 0648

    We are the Official Distributors for: P.3Key, Wode JukeBox, WasabiDX, WiiKey, DriveKey, M3i & More - Always Authentic Guarenteed !
    Buy Wode JukeBox v2.0 here: Here

  7. #7
    Junior Member
    Join Date
    Jul 2008
    Posts
    30
    Thanks
    0
    Thanked 2 Times in 2 Posts
    yeah i'm set to take it apart and take a look at the clip's seating tomorrow. the console has been moved around different places (in a duffel bag, sadly!) so there's a good chance it's loose. my chip had the 1.3 FW, as i got it from you guys (canadamods) very soon after you started to stock the v2

    inching and delayed disc recognition do not appear to happen to a predictable set of circumstances. finally got homebrew apps working with network again (press buttons, change things until it works) and got system menu down to 3.2U again, it started inching as soon as it rebooted :-p

    so yeah, time to open her back up. just wish i had some small phillips screws i could replace the tri-wing screws with when i do it.

  8. #8
    Wiihacks Recommended
    Pro Installer/Store
    Senior Member
    Spyman's Avatar
    Join Date
    Jun 2008
    Location
    Greater Toronto Area
    Posts
    1,546
    Thanks
    33
    Thanked 123 Times in 106 Posts
    Quote Originally Posted by bad duck View Post
    yeah i'm set to take it apart and take a look at the clip's seating tomorrow. the console has been moved around different places (in a duffel bag, sadly!) so there's a good chance it's loose. my chip had the 1.3 FW, as i got it from you guys (canadamods) very soon after you started to stock the v2

    inching and delayed disc recognition do not appear to happen to a predictable set of circumstances. finally got homebrew apps working with network again (press buttons, change things until it works) and got system menu down to 3.2U again, it started inching as soon as it rebooted :-p

    so yeah, time to open her back up. just wish i had some small phillips screws i could replace the tri-wing screws with when i do it.
    Well keep us updated, and I'll try to get those vids asap to help out. If you do need us to update your firmware we can do that for you.

    Al
    Send me a PM if you need any Canadamods.ca support

    $9.95 Flat Rate Shipping to Canada & USA
    Official Support for Canadamods. I am here to help.

    email: sales@canadamods.ca | website: http://www.canadamods.ca | Phone: +1 416 728 0648

    We are the Official Distributors for: P.3Key, Wode JukeBox, WasabiDX, WiiKey, DriveKey, M3i & More - Always Authentic Guarenteed !
    Buy Wode JukeBox v2.0 here: Here

  9. #9
    Junior Member
    Join Date
    Jul 2008
    Posts
    30
    Thanks
    0
    Thanked 2 Times in 2 Posts
    After taking WiiClip off and on a few times, it does seem like it might've been loose or not making good contact. Got it a good seating and tested it out with multiple discs, power cycles, etc.

    Only had inching occur once, and it was upon exiting a homebrew program (no disc in drive). Gave it a disc (it's funny watching an inching disc go in) and the inching stopped once disc was pulled in and recognized. Previously, it would continue even though the disc would be spinning up (frightening, IMO).

    Attempts to reproduce yields same -- perfectly normal operation, it would seem, when just loading discs, exiting to menu, eject / new game, repeat; it even took the same homebrew program to recreate inching (Kobo, uberfun). Rather than give it a disc, this time I gave it a power-cycle; stopped inching noise right after going down to standby, powered back up with one inch-noise and then the double-eject sound as seen in your install video (nice videos btw), then behaved normally.

    So for now, seems to be behaving as it should -- utility disc 1.6, sys menu 3.2U
    Would definitely suggest that identifying WiiClip installs when you hear of d2pro problems as a very viable possible cause of problem. Thanks for following along :-p

  10. #10
    Junior Member
    Join Date
    Jul 2008
    Posts
    30
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Spoke too soon. Inching and disc-not-recognized / disc-won't-eject back with a vengeance. ****. SHOOT ME IN THE HEAD this is ******* aggravating arguing with a goddamn console.

    d2pro is looking more and more like a piece of shit to me. Are there other chips that DON'T have this bullshit repeating problem on a D2C2? i've never been more continually aggravated by a malfunctioning device in my LIFE, and i'm ready to cut my monetary losses on this uber-bugged chip.

    MOD EDIT: Mind your language
    Last edited by jbloggs; 09-22-2008 at 05:23 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •