Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: D2Pro vs Argon

  1. #1
    Junior Member
    Join Date
    May 2008
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question D2Pro vs Argon

    Hello.

    I'm looking to mod my console like everyone else. I have searched the net for reviews and which one is better but everything seems to be outdated.

    I'm looking at either D2Pro with Solderless Clip for D2pro V4 or Argon with Solderless Clip V2 for Argon and JTAG / INJECTUS / ARGON PROGRAMMER USB from modchip.ca and I'm getting the clips pre-solder to the mod chips.

    According to my serial number I have 50% chance it is GC2-D2C and 50% chance it has pins on the drive chip not cut out.

    To this date, what is the better of these modchips. $$ is no question. I just want the best.

  2. #2
    Junior Member
    Join Date
    May 2008
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi,
    I'm also looking to get that question answered. From wht I've gathered, Argon claims to be the future of modchips with the SP1 flash and the usb programmer. Now I read in reviews that it the firmware wasn't stable but that it was all resolved thru the last update.

    On the other hand, most people on the forums seem to have either the wii-key or the D2Pro, plus the info about that chip looks like it is the most solid at the moment.

    Now can anybody shed some well needed light on this??

  3. #3
    Junior Member
    Join Date
    May 2008
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Angry

    I ended up going with Argon. I'll let you know how it goes because no one else wants to give the time of day to answer this.

  4. #4
    Admin / Super Mod ModderMan's Avatar
    Join Date
    Nov 2006
    Location
    GVR
    Posts
    8,841
    Thanks
    758
    Thanked 1,418 Times in 328 Posts
    Blog Entries
    15
    it could be that no one really has much actually real experience to be able to compare the argon to the old d2pro...... not that no one will give you the time of day. I just saw your post now.


    if the argon was stable....would be a great chip.....updates after updates, they can't get it right...now using wasabi code..but has porting problems still

    let us know how you do....with the clip and argon.....

    because of the problems from launch to now.... I would use the new d2pro9 or the Wasabi.... which have been running great...

    I wouldn't promote any products until they have proven themselves
    Last edited by ModderMan; 05-08-2008 at 02:01 PM.

    Wiihacks Super Mod / Admin

  5. #5
    Junior Member
    Join Date
    May 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I used the D2Pro (19 wire) on my wii. I have no complaints at all. Very happy. Never had to update it but I can with the Programmer if needed.

  6. #6
    Junior Member
    Join Date
    May 2008
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Ca

    Finally, I also went with the Argon pre-soldered to the clip. It's supposed to arrive early next week. I'll post my results after a few tests. Looking forward to opening up that little white box... I'm probably gong to do it myself, should be pretty simple. Did anyone out there open up their Wii and if so how much time did it take to do it and put it back together? How does it compare to a PS2?...






  7. #7
    Junior Member
    Join Date
    May 2008
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thumbs up Argon /w SPI and Wii-Clip working on Single Line GC2-D2C Chip

    I just installed the Argon /w SPI and Wii-Clip onto a D2C chip with SINGLE line only. ie. GC2-D2C and no numbers below it. Everything is works great except for Dual Layer Disc games. I think my DVD DL are working properly. I have to keep trying different media but single layer disc games works great.

    I have yet to solder the 4 extra wires for the region free.

  8. #8
    Admin / Super Mod ModderMan's Avatar
    Join Date
    Nov 2006
    Location
    GVR
    Posts
    8,841
    Thanks
    758
    Thanked 1,418 Times in 328 Posts
    Blog Entries
    15

    Thumbs up

    Quote Originally Posted by viper04 View Post
    I just installed the Argon /w SPI and Wii-Clip onto a D2C chip with SINGLE line only. ie. GC2-D2C and no numbers below it. Everything is works great except for Dual Layer Disc games. I think my DVD DL are working properly. I have to keep trying different media but single layer disc games works great.

    I have yet to solder the 4 extra wires for the region free.

    great to hear...

    ..... your ssbb is a burn problem..where does that game crash?

    also would u please post the 1st 9 digits of your serial# including the letters.....thx

    Wiihacks Super Mod / Admin

  9. #9
    Junior Member
    Join Date
    May 2008
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It crashes just before the startup scene just after the save file. I get a white screen.

    Serial is: LU569883

  10. #10
    Admin / Super Mod ModderMan's Avatar
    Join Date
    Nov 2006
    Location
    GVR
    Posts
    8,841
    Thanks
    758
    Thanked 1,418 Times in 328 Posts
    Blog Entries
    15
    burn problem.....

    did u set layer break to 2084960?

    and u r using verbatim dvd dl+r's?

    burning at 4X

    Wiihacks Super Mod / Admin

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •